0

I am using lightweight Linux, with Xorg, an minimal xbase-client for the only purpose to launch specific program on remote site.

These programs used by lambda users works well with a single default. When used on laptop computer with no digit-keypad the only way to type digits on entry fields is to use the upper line of the keyboard. The thing is that with an English/US keyboard there is no problems, but with a French keyboard if I type the keys 123 with shift I got 123, with nothing pressed I get &é" and with capslock pressed I get &É". But for most user when they are entring digigs they are used to set capslock on and directly type the digits. Which, in this case is not effective.

Is there a way to have capslock do the same as keeping shift while typing?

0

after digging around a few hours, I get this.

This is a general keyboard setting, both for console and Xorg. you can edit /etc/default/keyboard and set XKBOPTIONS="shift:breaks_caps,caps:shiftlock" the magic is in caps:shiftlock thing

then you need to

sudo dpkg-reconfigure keyboard-configuration
sudo service keyboard-setup restart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.