3

I'm trying to install Firefox on Alpine Linux. I ran

$ sudo apk add firefox

And a few hundred MBs later, it installed.

However, when I ran firefox, it crashed with symbol not found errors and something to do with libmozgtk and gtk+.

How do I fix this or is it not possible to run Firefox on a musl-based distro?

2
  • 1
    Welcome, sudo apk add firefox-esr
    – GAD3R
    May 23, 2019 at 21:36
  • Is there any difference? May 23, 2019 at 21:43

1 Answer 1

2

To install firefox on alpine linux enable the Community Repository:

add (or uncomment) a line like:

http://dl-cdn.alpinelinux.org/alpine/edge/community 

then run:

sudo apk update
sudo apk add firefox-esr

The package is called firefox on the edge branch:

Warning: "edge" is under constant development so be careful using it in production. It is possible that bugs in "edge" could cause data loss or could break your system.

Update

As said @OrangeDog firefox-esr (and firefox) is now available on the edge and v3.12 branch.

8
  • This works! Any difference between the packages though? May 27, 2019 at 20:24
  • 1
    firefox-esr stands for "Extended Support Release". The difference with firefox is explained here: mozilla.org/en-US/firefox/organizations Jul 18, 2019 at 7:01
  • 1
    firefox-esr is now in edge too
    – OrangeDog
    Nov 16, 2020 at 12:43
  • 1
    Thanks, I have the extended os version and need a minimal desktop to start firefox, is there a tutorial for Alpine similar to this for debian? Would the awesome desktop be minimal, sounds as if?
    – Timo
    Nov 18, 2020 at 9:28
  • 1
    @Timo Welcome! Sorry I can't find a good answer for you. I encourage you to post a new question. I am interrested.
    – GAD3R
    Nov 18, 2020 at 11:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .