2

When I was trying to install Docker on Deepin 15.10 via package repository, I had this error:

Error: could not find a distribution template for Deepin/stable

3

Since the OP never moved their Answer out of the Question, here's what they had originally.


Since Deepin 15.10, the base kernel is Debian stable, but in the Deepin distribution template is set as unstable; let's change that.

sudo nano /usr/share/python-apt/templates/Deepin.info

change

Suite: unstable

to

Suite: stable

and voilá, you now can add PPA without that problem above.

1

You should be able to add the repository manually.

Something like this:

curl -fsSL https://download.docker.com/linux/debian/gpg | sudo apt-key add -

printf 'deb [arch=amd64] https://download.docker.com/linux/debian stretch stable\n' \
| sudo tee /etc/apt/sources.list.d/docker-ce.list

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.