I recently installed Crunchbang 11 in the free space of a hard disk of an Asus netbook that already had Ubuntu installed on it.

I partitioned the 2 distros separately, with only a common swap space.

At the end of the installation, Crunchbang informed me that "it seems Crunchbang is the only OS on this system", and then asked me whether I would like to install GRUB. I said no and then it asked me again to choose a partition to install. I chose the "first on your hard disk" (which is supposed to belong to Ubuntu, anyway).

All cool, but needless to say Grub has no entry for Ubuntu during boot, and so Crunchbang is the only OS I can boot.

Is there a way (including reinstallation with proper options) that I could get Ubuntu as a GRUB option? Some way to add an entry to grub.cfg perhaps?


Using the boot repair disk image linked to on this official Ubuntu page, you can repair grub: https://help.ubuntu.com/community/Boot-Repair

CrunchBang and Ubuntu will both then be in grub as choices.


sudo update-grub (in a terminal) will also fix your issue.

  • Hi and welcome to Unix & Linux. Perhaps you could elaborate your answer slightly? Maybe add why you think this will fix the OP's issue? – slm Oct 7 '13 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.