0

This problem has been bothering me for months. I have a HP Envy Dv6 laptop, in which I installed Kali Linux. It has a dual gpu system with integrated graphics (Intel HD 4000) and dedicated GPU (Nvidia GeForce GTX635M).

I want to install Nvidia proprietary driver, so finally hashcat will see it and the screen tearing issue when using the os will be fixed. I tried to follow the official kali docs guide, which brought me to a frozen black screen with blinking "" on it after reboot. I found this guide on Kali forums, which I tried to follow step by step even a after a fresh new kali installation. No way, my pc still reboots to a blinking "" screen, from which I'm able to access my, system trough ctrl+alt+f2. From there, the only way to get back to a desktop environment is to purge all nvidia files.

I'm thinking the problem could be the erc/X11/xorg.conf file not configured well, because I managed to make it work from there just one time years ago, but I don't remember what I did.

Also, my idea is that the computer sees the graphic card, installs it successfully but then doesn't know in which screen to output it, because it gets confused by the presence of Intel card.

Anyone has idea about what can I do to troubleshoot/fix my problem? If you want screenshot, logs, pictures just ask, I'll provide them immediately.

0

Here is a suggestion for installing OpenSUSE Tumbleweed (as of April 2019) on a recent PC (Asus G20) with both Intel & nVidia (GTX970) graphics controllers:

  • in the BIOS settings, BOOT parameters, you can continue to use UEFI mode, but change the OS from "Windows" to "Other OS"

  • if your installation of OpenSUSE crashes, hangs, or fails with an unexpected error, try adding these options to the kernel boot line (press 'e' in the Grub boot screen): textmode=1 nomodeset acpi=off splash=verbose

  • you may need to do this each time when you run the 'Installation' or 'Update' option

  • after installing on an Asus G20, the following kernel options are recommended permanently, which you can set in Yast, Boot, Kernel parameters: pci=acpi pci=noaer splash=silent

  • also, it is suggested to install a minimum system in the non-graphics mode first, just to get the system running, then download the nVidia drivers for X using Yast from the Nvidia OpenSUSE repo, which is described here: https://en.opensuse.org/SDB:NVIDIA_drivers

  • install the appropriate for your graphics card. I used for a GTX970:

  • install the 'x11-video-nvidiaG05' driver, then reboot
  • install the 'nvidia-glG05' for OpenGL 3D acceleration
  • then run 'Update' to bring the system up to graphics mode

This problem was submitted to OpenSUSE.

Possible causes: - PCI Advaced Error Reporting (AER) floods the system log - possible conflicts between the Intel and nVidia controllers prior to nVidia drivers being installed cause crash

[end]

  • You've posted this exact answer to four different questions now. In each case, the distribution in use by the user and the graphics card model does not match that of the question. What makes you think following your suggested path would solve the issue on the users' distribution of Linux? Rather than repeating the same answer over and over, to questions that does not match it. Write you own question and post your answer to it. – Kusalananda Jun 12 at 5:43
  • I believe my answer does match this question, but you may be correct in the other cases. The writer asked for "an idea" or general help, so I am trying to be helpful. Thank you for your suggestion. – drsoaring Jun 13 at 19:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.