1

I know there are several topics regarding this however, none of these solve my problem. I've tried the different options mendtioned here

I have a router which exposed an attached disk via smb: \\192.168.1.1\diskname. No username required. The disk will be mounted at /mnt/diskname where the directory exists and has the permissions 777.

So I run this command

sudo mount -t cifs //192.168.1.1/diskname /mnt/diskname -o file_mode=0777,dir_mode=0777,rw,sec=none --verbose

which results in

mount.cifs kernel mount options: ip=192.168.1.1,unc=\\192.168.1.1\diskname,file_mode=0777,dir_mode=0777,sec=none,user=root,pass=********
mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
$ sudo lsmod | grep fuse       
fuse                  131072  5
$ sudo lsmod | grep cifs
cifs                 1077248  0
dns_resolver           16384  1 cifs
fscache               397312  1 cifs
$ mount.cifs --version
mount.cifs version: 6.8

Alternatively to sec=none I also tried user=,password=, which didnt't change the outcome.

0

Actually the only missing part was the vers=1.0 so when using it as additonal option the mout works. Apparently what it does - according to man mount.cifs

vers=arg
   SMB protocol version. Allowed values are:
   • 1.0 - The classic CIFS/SMBv1 protocol.
   • 2.0 - The SMBv2.002 protocol. This was initially introduced in Windows Vista Service Pack 1, and Windows Server 2008. Note that the initial release version of Windows Vista spoke a slightly different dialect (2.000) that is not supported.
   • 2.1 - The SMBv2.1 protocol that was introduced in Microsoft Windows 7 and Windows Server 2008R2.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.