I installed lighttpd and PHP on MySQL using the instructions in the accepted answer here:


Then I tried to configure my.cnf to allow remote access to MySQL using the instructions here:


When I type mysqld start or mysqld stop I get a seemingly never-ending stream of errors. It is too long to paste here, so I will mention a few:

[Note] Plugin 'FEDERATED' is disabled
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: Using the same InnoDB data or log files.
InnoDB: Retrying to lock the first data file
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Error in opening ./ibdata1
InnoDB: Error number 11 means 'Resource temporarily unavailable'.
InnoDB: If you tried to add new data files, and it failed here, you should now edit innodb_data_file_path in my.cnf back to what it was, and remove the new ibdata files InnoDB created in this failed attempt. InnoDB only wrote those files full of zeros, but did not yet use them in any way. But be careful: do not remove old data files which contain your preciious data!
[ERROR] Plugin 'InnoDB' init function returned error.
[ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
mysqld: Too many arguments (first extra is 'start').
[ERROR] Aborting

What should I do?


Looks to me you already have mysql daemon running. I have not checked the links above but if you have made an entry in /etc/rc.local or have /etc/rc.d/rc.mysqld you should know that these entries are used to launch mysql server during booting process.

Run nmap against your host after bootup to see if service is running.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.