0

I tried to install a thrid-party OpenWrt image to a computer. After writing the image file to SSD and start booting, the kernel message prints at a really slow pace, although some of the timestamp seems to be normal.

Here is the result of dmesg. The printing pace is mostly of 2 seconds for one line, but the timestamp only increased few milliseconds. As it's too long I posted it to Pastebin: https://paste.ubuntu.com/p/ZJKfXfGDSk/

Is that normal? It takes me about 5 minutes to complete the whole booting process. Once it boots, it works flawlessly. Also this phenomenon won't happen when using Legacy boot mode and the booting process takes about 6 seconds before you can press enter to access the console.

  • @Johan Myréen Please add as an answer so I can select as the best answer. That's exactly what the problem is. Thanks so much. – whc2001 May 22 at 14:01
  • may I ask you how you got Openwrt to boot on UEFI? – Mehdi Jun 10 at 13:35
  • @Mehdi I am using an 3rd party source and it comes with Build EFI GRUB images (Linux x86 or x86_64 host only) in the target image options. I believe there is no such option in the official source. – whc2001 Jun 12 at 4:17
  • can you please provide a link to that third party source? What I found now to be efi compatible is a still open pull request in the official github repository and another version from JOW git.openwrt.org/openwrt/staging/jow.git – Mehdi Jun 12 at 9:26
  • 1
    @Mehdi Here it is: github.com/coolsnowwolf/lede – whc2001 Jun 13 at 6:16
0

Remove console=ttyS0,115200n8r from the kernrl command line so the kernel doesn't try to write messages to the serial port, which is slowing down the boot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.