1

I am using awesome WM. When I start my window manager, I run setxkbmap -option compose:menu which has a ~/.XCompose with various extra definitions. Those work fine in Gvim, Firefox, Signal, and Slack (for example) but not in urxvt or anything under urxvt.

I tried using the above command as part of ~/.xprofile, as a run_once(…) command in awesome configuration, restarting all terminal, and nothing changes: the binding are not present in the terminal.

What am I missing here?

PS: Just in case, yes, the terminal has all the correct glyphs…

PS 2: I do not believe this is awesome specific but added in case it makes a difference.

1
+100

Apparently, urxvt does not respect ~/.XCompose, (See: man page).

Many distribution do also load settings from the ~/.Xresources file when X starts. urxvt will consult the following files/resources in order, with later settings overwriting earlier ones:

  1. app-defaults file in $XAPPLRESDIR
  2. $HOME/.Xdefaults
  3. RESOURCE_MANAGER property on root-window of screen 0
  4. SCREEN_RESOURCES property on root-window of the current screen
  5. $XENVIRONMENT file OR $HOME/.Xdefaults-
  6. resources specified via -xrm on the commandline

Also, urxvt has its own key bindings, (Also found in the man page), which may interfere with what you are trying to do.

Unfortunately, this will override built-in key mappings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.