0

I am trying to run the program ZereneStacker on Linux (I am using a Chromebook Samsung 3). I downloaded the program's .zip from here and extracted it. According to that download page, the .zip file includes:

ZereneStacker          executable launcher

ZereneStacker.bsh      launch script (provided for backward compatibility)

After extraction, I cd'd into the extracted folder ZereneStacker tried the commands

sudo chmod +x ZereneStacker
sudo ./ZereneStacker

and

sudo chmod +x ZereneStacker.bsh
sudo ./ZereneStacker.bsh

For both the output was long and included the following:

Fatal error: /home/user/ZereneStacker/jre/bin/java exists but is not an executable file

Do I need to change permissions further? Am I missing installation steps or should it install on first execution?


Here is the full output in case it is helpful:

sizeof(ptr) = 8
Physical memory = 2986188800
isSafeMode = 0
argv[0] = [/home/user/ZereneStacker/ZereneStacker]
launcherFile = [/home/user/ZereneStacker/ZereneStacker]
sigh... appdir = /home/user/ZereneStacker
arg0 = /home/user/ZereneStacker/ZereneStacker
argc = 1
endDir = /ZereneStacker
length = 33
argsLength = 0
appdir = /home/user/ZereneStacker
appdataName = /root/.ZereneStacker
appdataName = /root/.ZereneStacker
appdataZSName = /root/.ZereneStacker
configFileName = /root/.ZereneStacker/zerenstk.cfg
configFile = 0
mxStringFromConfig = 

mxString = -Xmx1024m
launchCmdFileName = /root/.ZereneStacker/zerenstk.launchcmd
launchOKFileName = /root/.ZereneStacker/zerenstk.launchOK
trying launchParamsFileName = /home/user/ZereneStacker/zerenstk.ini
initialization line = "{appdir}/jre/bin/java" {memsize} -DjavaBits={javaBits} -Dlaunchcmddir="{launchcmddir}" -classpath "{appdir}/ZereneStacker.jar:{appdir}/JREextensions/*" com.zerenesystems.stacker.gui.MainFrame

invocation line before possible tweaking = "/home/user/ZereneStacker/jre/bin/java" -Xmx1024m -DjavaBits=64bitJava -Dlaunchcmddir="/root/.ZereneStacker" -classpath "/home/user/ZereneStacker/ZereneStacker.jar:/home/user/ZereneStacker/JREextensions/*" com.zerenesystems.stacker.gui.MainFrame
argument 0 before tweaking: [/home/user/ZereneStacker/jre/bin/java]
argument 1 before tweaking: [-Xmx1024m]
argument 2 before tweaking: [-DjavaBits=64bitJava]
argument 3 before tweaking: [-Dlaunchcmddir=/root/.ZereneStacker]
argument 4 before tweaking: [-classpath]
argument 5 before tweaking: [/home/user/ZereneStacker/ZereneStacker.jar:/home/user/ZereneStacker/JREextensions/*]
argument 6 before tweaking: [com.zerenesystems.stacker.gui.MainFrame]
argument 7 before tweaking: [(null)]
Invocation line: ["/home/user/ZereneStacker/jre/bin/java" -Xmx1024m -DjavaBits=64bitJava -Dlaunchcmddir="/root/.ZereneStacker" -classpath "/home/user/ZereneStacker/ZereneStacker.jar:/home/user/ZereneStacker/JREextensions/*" com.zerenesystems.stacker.gui.MainFrame ]
statbuf.st_mode = 100644
Fatal error: /home/user/ZereneStacker/jre/bin/java exists but is not an executable file
| improve this question | | | | |
  • The FAQ on their website says this: "For...Linux, the downloaded file is a self-contained bundle that does not need to be “installed”. Just put it anywhere you like, typically either on your Desktop or in your Applications folder. The first time you run Zerene Stacker, it will go through a short process of configuring memory allocation based on what type of computer you have and how much physical memory it has installed. After this is done, the program will automatically restart..." – talker90 May 23 '19 at 16:16
0

With help from ZereneStacker support, I figured out the following solution:

sudo apt-get update
sudo apt-get upgrade
sudo apt install openjdk-8-jdk
sudo chmod +x ZereneStacker/*.zslinux
sudo chmod +x ZereneStacker/ZereneStacker.bsh
sudo chmod +x ZereneStacker/ZereneStacker
sudo chmod +x ZereneStacker/jre/bin/*
cd ZereneStacker
./ZereneStacker.bsh

This solution with openjdk-8-jdk worked even though Zerene Stacker has built-in 10.0.1 JRE. I only tried with openjdk-8-jdk

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.