0

I need to show our production logo on an ubuntu 18.04 server in kiosk mode. Because the kernel must be booted in text mode with framebuffer disabled, I try to edit a grub theme to show logo png image. After GRUB_THEME is set in /etc/default/grub:

GRUB_THEME="/boot/grub/themes/prodution/theme.txt" GRUB_TIMEOUT_STYLE="menu"

and boot menu is commented in theme.txt, only a logo image is shown. Then I can see boot logo when booting our machine. But when press up/down arrows on keyboard, the booting is paused. My question is: how to disable interactive keypresses on grub booting?

This is for ubuntu 18.04 server of text mode, root autologin is set in getty service.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.