0

I don't seem to have the option to "automatically unlock this key whenever I'm logged in" when trying to SSH into another computer.

This is a screenshot of my prompt: enter image description here

This is an example I found on some random website, but it shows where the option should appear: enter image description here

I have seahorse ssh-add ssh-agent ssh-askpass and seahorse-ssh-askpass all installed. The gnome-keyring-daemon is running in the background as well. I'm not sure why the option is missing. I've also tried ssh-add ~/.ssh/my_key and ssh-askpass ~/.ssh/my_key. I'll get prompted for the private key password, but the password is still required when I follow up with an SSH command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.