0

Today, just after a software upgrade which involved samba-libs, the gnome-conrol-center utility didn't start anymore when I tried to launch it from the small "tools" icon located at the top-right corner of the screen (under a gnome3 session).

Running instead gnome-control-center from a gnome-terminal works fine, although I got the following message on the terminal itself:

  (gnome-control-center:6766): network-cc-panel-WARNING **: 
  16:52:47.248: Error connecting to ModemManager: Errore nel chiamare 
  StartServiceByName per org.freedesktop.ModemManager1: 
  GDBus.Error:org.freedesktop.systemd1.NoSuchUnit: Unit dbus- 
  org.freedesktop.ModemManager1.service not found.

Is this related with the failure in launching the program from the icon?

My system is a Linux Fedora 29 and I work in a gnome-session. gnome-control-center installed on my system is gnome-control-center-3.30.3-1.fc29.x86_64 and samba-libs is samba-libs-4.9.8-0.fc29.x86_64

Can anyone understand where is the problem? Thanks in advance.

  • Somewhere it was suggested to execute killall on the gnome-control-center process, but this didn't work in my case: the process doesn't hang; it simply doesn't start. – GSi May 22 at 7:35
0

I solved the issue: there was something wrong inside the .local directory in my $HOME. I didn't investigate what, but it has been enough to remove that directory and let the system create a new one to get all working. I had only to pay the reintroduction by hand of my passwords for the mail client evolution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.