0

If I run the following on the Linux or Mac OSX host, I have no problem:

# ssh -i id_rsa -MS ./ctrl -fTN -p22 -l root example.com
# ssh -S ./ctrl -O check example.com
Master running (pid=23384)

However if I try it inside the alpine-linux container on Mac OSX, it doesn't work:

# ssh -i id_rsa -MS ./ctrl -fTN -p22 -l root example.com
# ssh -S ./ctrl -O check example.com
Control socket connect(./ctrl): Connection refused

It's only happening when the container is running on the Mac OSX, as I didn't observe the same behaviour on Linux. Interestingly port forwarding (-L option) via unix-socket still works without a problem.

# apk list | grep ssh
WARNING: Ignoring APKINDEX.b89edf6e.tar.gz: No such file or directory
WARNING: Ignoring APKINDEX.737f7e01.tar.gz: No such file or directory
openssh-client-7.9_p1-r5 x86_64 {openssh} (BSD) [installed]
openssh-keygen-7.9_p1-r5 x86_64 {openssh} (BSD) [installed]
autossh-1.4f-r0 x86_64 {autossh} (BSD) [installed]

Docker on OSX:

$ docker --version
Docker version 18.09.2, build 6247962

Docker on Linux:

docker --version
Docker version 18.09.3, build 774a1f4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.