Synapse launcher is able to show various files (text, media) on one of my ntfs partitions (that I use in parallel from Windows too), but cannot open those files, while it can open files from my Linux partition, my home files.

In my case is Synapse 0.2.99 in Mint 19.1.


This is a bug described here.

It involves the fact described here.

Synapse broke how things work with files with executable permission. If it has executable permission it tries to execute file instead of opening file with relevant app.

So, as said at that link, a solution would be to remove the executable permission for all such files or, as said here, add noexec in the options column of /etc/fstab for that partition.

I prefer to use "Disks" (gnome-disk-utility, can be run as gnome-disks) in order to automatically mount that partition.

So, in "Disks", selecting that partition and its mount options, (where I had already) unchecked the defaults and checked to mount at startup (setting a mount point): the solution was to add noexec at the list of options for that partition.

enter image description here

After reboot Synapse was able to open all files in their relevant applications.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.