0

Recently my old dell laptop started to work very slowly, so I decided to install linux on it. I choosed debian (cause i like it). everything was ok, i installed drivers, programs etc. but when I tried to connect to my wi-fi (before i had used ethernet) it didn't detect it (but detected 30 routers of my neighbors). However when i tried to use my phone as hotspot it worked. How i can fix it? Spec: router ASUS RT-N56U (it offer 5GHz but I use 2.4 istead [idk why, don't ask]) (SSID rubikon) laptop DELL inspirion 1545

ip link show lspci

  • 4
    Is it you network 5GHz? – Romeo Ninov May 19 at 14:28
  • Please edit your question to add some essential information: the make and model of your WiFi adapter/chip. First run ip link show or ifconfig -a to list all detected network adapters; typically the WiFi adapter is named either wlan0 or wlo1 but it might be different. Then run ethtool -i <WiFi adapter name> and edit the output into your question, please. The outputs of lspci -nn and/or lsusb (whichever is appropriate) would be useful too. Some Broadcom WiFi chips have a very limited list of channels supported when the reverse-engineered b43 driver is used. – telcoM May 19 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.