0

I have a keyboard that has an american layout and I need to use it for portuguese locale. On Windows and Mac this usually defaults to a setting named "US International", but none of the similar keyboard options present in this Linux (Ubuntu 18, xfce) behave with the extra key "chords" that I need, although the layout mapping is ok.

Some examples of the key combinations I am looking to achieve (those come as default on Windows):

  • ' + c = ç
  • ' + ' = ' (2x any chord key will output it)
  • " + u = ü
  • ' + e = é

and it goes on. Basically all of the accent keys never output on the 1st press, but instead wait for a second press.

On all of the "US Intl" layouts present by default on linux, pressing ' will immediately output the accent instead of waiting for the 2nd press. How should I proceed to get a behaviour similar to that I get in Windows?

5
  • 2
    You might have to define a couple of custom dead keys. In a long distant past, I had such configuration when I refused to use a PT keyboard. Cant remember however whether I was using a PT locale. Commented May 18, 2019 at 17:06
  • 1
    see askubuntu.com/questions/1045352/… Commented May 18, 2019 at 17:29
  • Ive already seen those alternate solutions (like using altGr and sort) dozens of times, for me they are just an ugly workaround. I want the real solution (id even dig to implement it when I have time), its quite sad that a feature that has been working on the other systems for more than 15 years is still not implemented on linux... Like, even windows 3.x already had a decent keyboard layout for that,
    – wkrueger
    Commented May 18, 2019 at 19:39
  • 1
    Nothing prevents you from defining any key you want as dead key if you know how to do it. As for myself, if I defined the true , ~ and `´ as dead keys, I would kill myself when programming or writing in English. Hence probably the altGr solutions. Mapping them as dead keys is a much more cumbersome solution IMO Commented May 18, 2019 at 19:57
  • thats what ill look into soon, thanks
    – wkrueger
    Commented May 19, 2019 at 22:04

1 Answer 1

3

IMHO, the best solution: Why is the US international keyboard layout on Debian different?

So, English US international with dead keys works exactly as needed. I have a Logitech Ergo K860.

It took me forever to find a decent solution so I'm paying it forward.

OP EDIT:

Summary from article:

  1. Have the "English Us Intl. With Dead Keys" layout enabled (this is usually available in most UIs)
  2. Have the following env variable set (you can edit /etc/locale.conf or append to ~/.profile)
export LC_CTYPE=pt_BR.UTF-8

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .