-3
[root@tomcat bin]# yum install docker-ce docker-ce-cli containerd.io
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: centos.vargonen.com
 * epel: mirror.de.leaseweb.net
 * extras: centos.vargonen.com
 * rpmforge: mirrors.nav.ro
 * updates: centos.vargonen.com
docker-ce-stable                                                                                                                                                                                                      | 3.5 kB     00:00
docker-ce-stable/primary_db                                                                                                                                                                                           |  28 kB     00:00
docker-ce-test                                                                                                                                                                                                        | 3.5 kB     00:00
docker-ce-test/primary_db                                                                                                                                                                                             |  87 kB     00:00
Resolving Dependencies
--> Running transaction check
---> Package containerd.io.x86_64 0:1.2.5-3.1.el7 will be installed
--> Processing Dependency: systemd for package: containerd.io-1.2.5-3.1.el7.x86_64
--> Processing Dependency: systemd for package: containerd.io-1.2.5-3.1.el7.x86_64
---> Package docker-ce.x86_64 3:19.03.0-1.4.beta4.el7 will be installed
--> Processing Dependency: container-selinux >= 2.9 for package: 3:docker-ce-19.03.0-1.4.beta4.el7.x86_64
--> Processing Dependency: libseccomp >= 2.3 for package: 3:docker-ce-19.03.0-1.4.beta4.el7.x86_64
--> Processing Dependency: libcgroup for package: 3:docker-ce-19.03.0-1.4.beta4.el7.x86_64
--> Processing Dependency: libsystemd.so.0(LIBSYSTEMD_209)(64bit) for package: 3:docker-ce-19.03.0-1.4.beta4.el7.x86_64
--> Processing Dependency: systemd-units for package: 3:docker-ce-19.03.0-1.4.beta4.el7.x86_64
--> Processing Dependency: xz for package: 3:docker-ce-19.03.0-1.4.beta4.el7.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: 3:docker-ce-19.03.0-1.4.beta4.el7.x86_64
--> Processing Dependency: libseccomp.so.2()(64bit) for package: 3:docker-ce-19.03.0-1.4.beta4.el7.x86_64
--> Processing Dependency: libsystemd.so.0()(64bit) for package: 3:docker-ce-19.03.0-1.4.beta4.el7.x86_64
---> Package docker-ce-cli.x86_64 1:19.03.0-1.4.beta4.el7 will be installed
--> Running transaction check
---> Package containerd.io.x86_64 0:1.2.5-3.1.el7 will be installed
--> Processing Dependency: systemd for package: containerd.io-1.2.5-3.1.el7.x86_64
--> Processing Dependency: systemd for package: containerd.io-1.2.5-3.1.el7.x86_64
---> Package docker-ce.x86_64 3:19.03.0-1.4.beta4.el7 will be installed
--> Processing Dependency: container-selinux >= 2.9 for package: 3:docker-ce-19.03.0-1.4.beta4.el7.x86_64
--> Processing Dependency: libseccomp >= 2.3 for package: 3:docker-ce-19.03.0-1.4.beta4.el7.x86_64
--> Processing Dependency: libsystemd.so.0(LIBSYSTEMD_209)(64bit) for package: 3:docker-ce-19.03.0-1.4.beta4.el7.x86_64
--> Processing Dependency: systemd-units for package: 3:docker-ce-19.03.0-1.4.beta4.el7.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: 3:docker-ce-19.03.0-1.4.beta4.el7.x86_64
--> Processing Dependency: libseccomp.so.2()(64bit) for package: 3:docker-ce-19.03.0-1.4.beta4.el7.x86_64
--> Processing Dependency: libsystemd.so.0()(64bit) for package: 3:docker-ce-19.03.0-1.4.beta4.el7.x86_64
---> Package libcgroup.x86_64 0:0.40.rc1-27.el6_10 will be installed
---> Package xz.x86_64 0:4.999.9-0.5.beta.20091007git.el6 will be installed
--> Finished Dependency Resolution
Error: Package: 3:docker-ce-19.03.0-1.4.beta4.el7.x86_64 (docker-ce-test)
           Requires: libc.so.6(GLIBC_2.17)(64bit)
Error: Package: 3:docker-ce-19.03.0-1.4.beta4.el7.x86_64 (docker-ce-test)
           Requires: systemd-units
Error: Package: 3:docker-ce-19.03.0-1.4.beta4.el7.x86_64 (docker-ce-test)
           Requires: libsystemd.so.0()(64bit)
Error: Package: 3:docker-ce-19.03.0-1.4.beta4.el7.x86_64 (docker-ce-test)
           Requires: libseccomp.so.2()(64bit)
Error: Package: 3:docker-ce-19.03.0-1.4.beta4.el7.x86_64 (docker-ce-test)
           Requires: libsystemd.so.0(LIBSYSTEMD_209)(64bit)
Error: Package: 3:docker-ce-19.03.0-1.4.beta4.el7.x86_64 (docker-ce-test)
           Requires: container-selinux >= 2.9
Error: Package: containerd.io-1.2.5-3.1.el7.x86_64 (docker-ce-stable)
           Requires: systemd
Error: Package: 3:docker-ce-19.03.0-1.4.beta4.el7.x86_64 (docker-ce-test)
           Requires: libseccomp >= 2.3
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I get this error.

i follow this tutorial.

https://docs.docker.com/install/linux/docker-ce/centos/

I made

--skip-broken

but this time

[root@tomcat bin]# systemctl start docker
-bash: systemctl: command not found
[root@tomcat bin]# docker run hello-world
docker: Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?.
See 'docker run --help'.
[root@tomcat bin]# service docker start
docker: unrecognized service

i got those errors

  • 1
    You are trying to install software for CentOS 7 on CentOS 6. Same problem as in your other question: unix.stackexchange.com/questions/519027/… – Panki May 17 at 14:12
  • @Panki i could not find any guides for centos6 – Caner Aydın May 17 at 14:26
  • ... and why is that? Because it's not supported! – Panki May 17 at 14:29
3

docker-ce isn't supported on centos 6.

OS requirements

To install Docker CE, you need a maintained version of CentOS 7. Archived versions aren’t supported or tested.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.