0

I have a server and just finished building my raids. One of the partitions is supposed to house my home folders which I then want to share with my windows computers through samba. Before I begin migration of all my data I created a user to test if I can move my home folders from /home/<user> over to the path /mnt/volume1/homes/<user>. The move worked without problems through usermod -m -d /mnt/volume1/homes user, just the access to the share stops working after the move.

I logged in to smbclient with the user and when I enter ls or dir all I get is NT_STATUS_ACCESS_DENIED LISTING /*. I made sure the user has full control over the folder with setfacl -R -m u:<user>:rwx /mnt/volume1/homes/<user> in addition to being owner, for the user himself as well as the group. When I login to the smbclient accessing the original home folder in /home/<user> everything works like a charm.

I also tried solution here but that didn't work either. I also found a post that suggested to execute sudo chcon -R -t samba_share_t /mnt/volume1/homes/<user> but that did not work.

My question: How do I have to create or move the homes shares to the position /mnt/volume1/homes and configure Samba so I can access them.

0

by accident I discovered the solution to my issue. Setting the rights with setfacl was the right solution just the level I applied these rights to was not right. I had them assigned to only the users folder /mnt/volume1/homes/<user>. The right level was to set these rights the level /mnt/volume1/. Once I set these rights on that level, everything worked like a charm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.