-1

I am getting the errors shown below when trying to install a python package on CentOs machine using software collection. I am wondering if it is related to the version of CentOs used and the version of the python package is being installed?

Package: rh-python36-python-libs-3.6.3-1.el6.x86_6 (/rh-python36-python-libs-3.6.3-1.el6.x86_64)  Requires: libffi.so.5()(64bit)
Package: rh-python36-python-libs-3.6.3-1.el6.x86_64 (/rh-python36-python-libs-3.6.3-1.el6.x86_64) Requires: libgdbm.so.2()(64bit)

I would like to know the reason behind these errors

  • I do not see that rh-python36 is officially provided for CentOS 6, where did these packages come from? CentOS 6 looks to provide python33 and sclo-python35 in the Software Collections. If you are rebuilding packages from a different version, did you make sure the dependencies of those packages were available in CentOS 6? Is your CentOS 6 system 64bit? – GracefulRestart May 16 at 20:57
  • You are right ! thanks – Ali Amin May 17 at 9:39
0

Don't use CentOs 6 packages on CentOs 7 systems.

You can check the part between brackets below to verify if it is Centos 6 or 7

rh-python36-python-libs-3.6.3-1.{{el6}}.x86_6

In this case, it is of version 6 and I was using CentOs 7.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.