0

I am trying to install dockerce on redhat7 by following the below steps

yum update -y

yum-config-manager --add-repo https://download.docker.com/linux/centos/docker-ce.repo

yum install docker-ce -y

I have got the below errors

---> Package docker-ce-cli.x86_64 1:18.09.6-3.el7 will be installed --> Finished Dependency Resolution

Error: Package: 3:docker-ce-18.09.6-3.el7.x86_64 (docker-ce-stable) Requires: libcgroup

Error: Package: 3:docker-ce-18.09.6-3.el7.x86_64 (docker-ce-stable) Requires: libseccomp >= 2.3

Error: Package: 3:docker-ce-18.09.6-3.el7.x86_64 (docker-ce-stable) Requires: container-selinux >= 2.9

Error: Package: 3:docker-ce-18.09.6-3.el7.x86_64 (docker-ce-stable) Requires: libseccomp.so.2()(64bit)

You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

  • what happens if you do yumdownloader --resolve docker-ce ? If you dont have yumdownloader then install with yum install yum-utils must be run by root user with full privileges. – Rakib Fiha May 16 at 10:58
  • Thanks @RakibFiha , but Unfortunately it doesn't work – Elsayed May 16 at 11:07
1

You need to enable=1 the [rhel-7-server-extras-rpms] repository in /etc/yum.repos.d/redhat.repo.

Then you can try again : yum install docker-ce docker-ce-cli containerd.io

0

Have you tried clearing up the yum and then installing the docker?

yum clean all

yum install docker-ce

  • Thanks so much for your reply @Srikanth , but unfortunately it doesn't work – Elsayed May 16 at 10:41
0

You have certain dependencies that are not resolving.

Please use the below and let me know if the installation goes through.

sudo yum-config-manager --enable rhui-REGION-rhel-server-extras

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.