Our Kubuntu computers are configured to automatically connect to their network drive via AutoFS. When we upgrade machines to Kubuntu 18.04 LTS this AutoFS connection no longer works. It is still working fine in Kubuntu 14.04 LTS and Kubuntu 16.04 LTS.

Debug Mode

I have run autoFS (automount) in debug mode:

automount -f -d

.. and receive the following error:

mount error(126): **Required key not available**
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I can use klist and see a kerberos key is present but still won't map (why?)

Now after some fooling around the kerberos key now works reliably only in debug mode (automount -f -d). It doesn't work at all when run as a service (service autofs start). Why does it only work in debug mode..?

Log : Error

Here is the error in daemon.log :

May 16 17:49:02 computer1234 cifs.upcall: get_cachename_from_process_env: pathname=/proc/1234/environ  
May 16 17:49:02 computer1234 cifs.upcall: get_existing_cc: default ccache is FILE:/tmp/krb5cc_12345678  
May 16 17:49:02 computer1234 cifs.upcall: get_tgt_time: unable to get principal  
May 16 17:49:02 computer1234 cifs.upcall: krb5_get_init_creds_keytab: -1765328174  
May 16 17:49:02 computer1234 cifs.upcall: Exit status 1


I had tried adding '-t' in /etc/request-key.d/cifs.spnego.conf and it still was not working

If you have similar problem you can try adding logging = "verbose" or logging = "debug" in /etc/autofs.conf to get more detail.


Yesterday we noticed that autofs is looking for the kerberos ticket file named in this format: /tmp/krb5cc_12345678

However the actual kerberos ticket file name has 7 more chars at the end and looks like this: /tmp/krb5cc_12345678_1A23B4


As per UPDATE 2 above, the issue was that autofs is looking for a kerberos ticket named in this format:


But the actual kerberos ticket was named in this format:


To fix the file names edit /etc/sssd/sssd.conf and add the following under the relevant domain section, ie. under [domain/yourAD_ServerName]


I had to reboot in order to get these changes to take effect. I tried restarting sssd-secrets, sssd, and autofs but that wasn't enough. Only after a reboot were the filenames in the right format, and then autofs worked properly in Kubuntu 18.04 LTS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.