I installed centos 6.3 Final . But after rebooting it stuck and doesn't show GUI

enter image description here


I guess you need to start X-Windows manually.

  1. Login on command prompt
  2. run startx

Configuring to make it run automatically:

X Window System

  • 2
    sorry it didn't work. When i run the startx command it reply -bash: startx command not found – OmiPenguin Oct 15 '12 at 18:55
  • 2
    Apparently "X Window System" is not installed on your VirtualBox to save space. You need to install it if you can't do without it. – SparKot Oct 15 '12 at 19:04

I just had the same issue, but in my case it was too little RAM. (On about the 10th install attempt I saw a message flash up very briefly stating this).

It seems that if you have too little RAM or video memory it defaults to a text mode installer and does not install X.

1GB was enough (started with 512MB)


Dear I also did this right after @Spackot reply but in vain.

It gave me some repositories error although I was connected to internet but still it happened.So i simply reinstalled centos.

But this time I checked the video memory settings. And there were only 1MB memory assigned by default so I assigned 70MB and also selected 3rd option while Booting. Which is Install OS which Basic Video drivers and it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.