0

I am trying to install SVP (SmoothVideo Project) on Linux Mint 19.1 and I am running into problems with Vapoursynth installation. When I try to do the part "Building 3rd-party apps from sources -> Vapoursynth -> # build Vapoursynth! -> make -j4" (found in here: https://www.svp-team.com/wiki/SVP:Linux) I run into an error:

Fatal error: can't create src/core/.libs/libvapoursynth_la-cachefilter.o: Permission denied

Here is the full code:

  CXX      src/core/libvapoursynth_la-boxblurfilter.lo
  CXX      src/core/libvapoursynth_la-cachefilter.lo
  CC       src/core/libvapoursynth_la-cpufeatures.lo
  CXX      src/core/libvapoursynth_la-exprfilter.lo
rm: cannot remove 'src/core/.libs/libvapoursynth_la-cpufeatures.o': Permission denied
rm: cannot remove 'src/core/.libs/libvapoursynth_la-cachefilter.o': Permission denied
rm: cannot remove 'src/core/.libs/libvapoursynth_la-boxblurfilter.o': Permission denied
rm: cannot remove 'src/core/.libs/libvapoursynth_la-exprfilter.o': Permission denied
Assembler messages:
Fatal error: can't create src/core/.libs/libvapoursynth_la-cpufeatures.o: Permission denied
Makefile:1322: recipe for target 'src/core/libvapoursynth_la-cpufeatures.lo' failed
make: *** [src/core/libvapoursynth_la-cpufeatures.lo] Error 1
make: *** Waiting for unfinished jobs....
Assembler messages:
Fatal error: can't create src/core/.libs/libvapoursynth_la-boxblurfilter.o: Permission denied
Makefile:1472: recipe for target 'src/core/libvapoursynth_la-boxblurfilter.lo' failed
make: *** [src/core/libvapoursynth_la-boxblurfilter.lo] Error 1
In file included from src/core/exprfilter.cpp:38:0:
src/core/jitasm.h: In constructor ‘jitasm::detail::ResultT<float, 4>::ResultT(float)’:
src/core/jitasm.h:8533:52: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
   ResultT(const float imm) : val_(Imm32(*(uint32*)&imm)) {}
                                                    ^~~
src/core/jitasm.h: In member function ‘void jitasm::detail::ResultT<double, 8>::StoreResult(jitasm::Frontend&, const jitasm::detail::ResultDest&)’:
src/core/jitasm.h:8608:67: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
     f.mov(f.dword_ptr[f.rsp - 8], *reinterpret_cast<uint32*>(&imm_));
                                                                   ^
Assembler messages:
Fatal error: can't create src/core/.libs/libvapoursynth_la-cachefilter.o: Permission denied
Makefile:1479: recipe for target 'src/core/libvapoursynth_la-cachefilter.lo' failed
make: *** [src/core/libvapoursynth_la-cachefilter.lo] Error 1
Assembler messages:
Fatal error: can't create src/core/.libs/libvapoursynth_la-exprfilter.o: Permission denied
Makefile:1486: recipe for target 'src/core/libvapoursynth_la-exprfilter.lo' failed
make: *** [src/core/libvapoursynth_la-exprfilter.lo] Error 1

I have installed the latest Python and Cython and that fixed some of my problems, but this problem still persists. I guess I should somehow give permission for it, but I don't know how, since I am quite new to the Linux world.

EDIT: I fixed this by running 'sudo make clean', for some reason 'make clean' did not clean it all the way. But now I am faced with a new problem. Something called "vspipe" keeps throwing error. Here is the error code:

Error compiling Cython file:
------------------------------------------------------------
...
        # If we are not using VSScript, do nothing.
        if self.single:
            return
        _environment_state.current = _env_current_stack().pop()

    def __eq__(self, other):
   ^
------------------------------------------------------------

src/cython/vapoursynth.pyx:133:4: Special method __eq__ must be implemented via __richcmp__
  CXX      src/vspipe/vspipe.o
Makefile:2019: recipe for target 'src/cython/vapoursynth.c' failed
make: *** [src/cython/vapoursynth.c] Error 1
make: *** Waiting for unfinished jobs....
  • Did you run some of the build as root only to then try to re-build using a non-privileged user? – Kusalananda May 15 at 16:05
  • Doesn't anyone know how to fix this? I have googled vspipe error but have found no solution. – Crossoni May 16 at 15:58
0

The error message means that Cython is out of date. Use pip3 to update it.

pip3 install Cython
  • Wow that fixed the problem. Thank you so much! – Crossoni Jun 30 at 8:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.