1

I installed CentOS on my machine from my USB. I did a minimal CentOS USB drive with UNetbootin. After I install the CentOS, when i try to reboot, it does not starts. I have only the cursor blinking on a black screen.

Note: If I install the boot loader on flash drive, the system starts correctly when the USB drive is plugged in. But if I install the boot loader on HDD, I can't boot.

Can anybody help me on solving this issue?


EDIT 1 After I installed the boot loader on USB drive, I can log in (even if I unplug the flash drive after grub menu, I can load in). Here is explained what I did after I did this:

I ran:

grub-install /dev/sda

outputs (show only last lines):


(hd1)  /dev/sda
(hd0)  /dev/sdb

this is the content of /boot/grub/device.map file.

Now if I run reboot without the flash drive plugged in, I get this message:

failed to read image

press any key to enter the menu

  • it sounds like you installed the OS from your USB drive back onto your USB. Can you boot into a live cd and verify that your HDD mounts and the files are there to include /boot/<kernel> – h3rrmiller Oct 15 '12 at 11:56
  • Looks like disk order is incorrect, can you show your grub config file? – daisy Oct 15 '12 at 12:02
  • @h3rrmiller I don't have an optical unit on my server. But this can't be possible because I installed CentOS on many partitions under /dev/sdb, while USB flash drive is mounted under /dev/sda – artaxerxe Oct 15 '12 at 12:02
  • @warl0ck No. Because I don't have access to OS files now. I installed the boot loader on the HDD and I can't start the system anymore. – artaxerxe Oct 15 '12 at 12:04
  • @warl0ck See EDIT 1 – artaxerxe Oct 15 '12 at 12:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.