0

I started a vsftpd server on my arch linux desktop and then tried to log in to it using using my normal user. But I get "530 Login incorrect" when I attempt to log in:

$ systemctl start vsftpd

$ groups
wheel tom

$ hostname
desktop

$ ftp desktop
Connected to desktop.localdomain.
220 Just to make extra sure the server is configured by this file.
Name (desktop:tom):
331 Please specify the password.
Password:
530 Login incorrect.
ftp: Login failed.
ftp> 221 Goodbye.

/etc/vsftpd.conf

anonymous_enable=NO
local_enable=YES
write_enable=YES
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
ftpd_banner=Just to make extra sure the server is configured by this file.
listen=YES

# I also tried different combinations of these, no dice
# seccomp_sandbox=NO
# pam_service_name=ftp

Is there any config change that will fix this and enable me to log in? I can't tell what I'm doing differently from everyone else.

0

/etc/vsftpd.conf:

pam_service_name=vsftpd

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.