0

I installed Spark and during the installation I think I changed some settings in .bash_profile.

Now, when I try to compile with Markdown I get the following error:

Restarting R session...

Error: 2:85: unexpected numeric constant
2: lib_path <- c(lib_path,"/MyDirectory/spark-1.4.0/R/lib")/Users/mac/Desktop/spark-2.4.2
                                                                                        ^

here is the body of .bash_profile:

# Setting PATH for Python 3.6
# The original version is saved in .bash_profile.pysave
PATH="/Library/Frameworks/Python.framework/Versions/3.6/bin:${PATH}"
export PATH

# Setting PATH for Python 3.7
# The original version is saved in .bash_profile.pysave
PATH="/Library/Frameworks/Python.framework/Versions/3.7/bin:${PATH}"
export PATH
# added by Anaconda3 5.3.1 installer
# >>> conda init >>>
# !! Contents within this block are managed by 'conda init' !!
__conda_setup="$(CONDA_REPORT_ERRORS=false '/Users/mac/anaconda3/bin/conda' shell.bash hook 2> /dev/null)"
if [ $? -eq 0 ]; then
    \eval "$__conda_setup"
else
    if [ -f "/Users/mac/anaconda3/etc/profile.d/conda.sh" ]; then
        . "/Users/mac/anaconda3/etc/profile.d/conda.sh"
        CONDA_CHANGEPS1=false conda activate base
    else
        \export PATH="/Users/mac/anaconda3/bin:$PATH"
    fi
fi
unset __conda_setup
# <<< conda init <<<

export PATH=${PATH}:/Users/mac/mysql/bin/

I can not fix the problem.

| improve this question | | | | |
  • Welcome; could you edit your question to explain what settings you changed? If you don’t know, you could include the contents of your .bash_profile... – Stephen Kitt May 14 '19 at 15:16
  • What have you already tried as a fix to this problem? Please provide examples of what has not worked, what you have researched, etc. – 0xSheepdog May 14 '19 at 15:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.