1

The touchpad and trackpoint on my ThinkPad x250 had gained the habit of not working pretty much all of the time now. At first, it appeared to be that after sleep it stopped working, then it gradually became worse and even after restarting I can not make it work again.

I have tried using libinput and synaptics drivers, as well as cutting edge and LTS version of Linux too. I have tried restarting in in a different shell as well as just in standart terminal by using:

$ modprobe -r psmouse
$ modprobe psmouse

What returns after xinput list and libinput list-devices doesn't include touchpad when it is not working. When it works they're listed there as well.

$ xinput list
⎡ Virtual core pointer                          id=2    [master pointer  (3)]                                                                                                                               
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]                                                                                                                             
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]                                                                                                                               
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]                                                                                                                               
    ↳ Power Button                              id=6    [slave  keyboard (3)]                                                                                                                               
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]                                                                                                                               
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]                                                                                                                               
    ↳ Integrated Camera: Integrated C           id=9    [slave  keyboard (3)]                                                                                                                               
    ↳ AT Translated Set 2 keyboard              id=10   [slave  keyboard (3)]                                                                                                                               
    ↳ ThinkPad Extra Buttons                    id=11   [slave  keyboard (3)] 

Do I have any way to know if this is hardware or software related?

  • When it's not working it doesn't appear to be plugged in? You have a loss connection. Possibly a cable disconnecting. Possibly thermal expansion/contraction making/breaking a connection. Either way, it's hardware. – SHawarden May 14 '19 at 9:53
  • What made me wonder is that both TrackPoint and touchpad don't work at the same time. I don't know about their connection in the build of ThinkPad x250. That's why I thought it could be software related. Because they are sold separately. – Yanek Yuk May 14 '19 at 10:08
0

This was hardware related. I had to replace both the cable and the touchpad to fix this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.