I wanted to extend my / partition from 20GB to 100GB by taking 80GB from the /home partition.

  • My / is on sda3
  • My /home is on sda5

So I used gparted and moved the front of sda5 right to subtract the 80GB, but i didn't know it would move all of my sda5 data 80gb ahead, and that this process would take 10hours.

I have a weak internet connection to my server and if the ssh connection gets dropped all the data could potentially get lost as I am doing this in rescue mode using qemu-kvm and forgot to start screen before starting this process.

Is there any way to cancel the resize of my 2TB drive without it being corrupted?

Because in the meantime, I figured out it would have been much faster if I moved sda3 to the end of the disk after shrinking sda5 by 80GB.

EDIT: The process is completed. I used repytr to move the process from SSH to screen and god it worked fine.


From the data we've been given, I'm assuming the following:

  • You did not take a 10h system backup before you started
  • You have a weak internet connection and the ssh session might be lost

So under the current situation, the best thing to do is:

  • start a ping to the host so the connection is kept alive
  • Wait for 10 hours

Depending on the outcome, you just:

  • reboot your system and everything is fine
  • have the service provider / DCOps / ... reboot the host after they've confirmed there is no high load on the disks any more.

If you would have used parted instead of gparted to do the resize, you could have stopped the resize as it does the resize by moving the last allocated blocks first and then goes to the front and only updates the partition table if everything went fine.

However as you're using the GUI, the results are unpredictable, so the best thing to do now is wait...

Note: Next time, take a system backup before doing things like this and use the command line instead of the GUI, which forces you to think before doing....

  • The process is completed. I used repytr to move the process from SSH to screen and god it worked fine. – Harsh May 13 at 19:46
  • @Harsh I'm happy for you... :-) As you've never accepted an answer on this site before: If one of the answers solved your problem, don't forget to click the grey at the left of its text, which means Yes, this answer is the most useful of all! ;-) – Fabby May 14 at 12:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.