0

I'm unable to login to my Fedora 28 system. I have a dual boot system with Fedora 29 and 28. I often use the Fedora 29 system and now booting the Fedora 28 after long days say around 2 months.

I'm getting to the graphical login screen. After entering the username and password the login screens is reappearing and asking me to re-enter username and password. If I intentionally enter wrong credentials, the login screen is detecting and showing a wrong credential is given.

I switched to the terminal using alt+ctrl+f2. The same issue is appearing again. I'm entering my login credentials on the terminal, the terminal is again asking me for the credentials.

I'm unsure where to start debugging? I disabled graphical login by deleting rhgb quit from the grub command line. I found the following potentially meaningful error message during boot

Failed to start User Manager for UID 42
See 'systemctl status user@42.service' for details

Further, I logged in to the single user mode using grub command init=/bin/bash. I checked /var/log/Xorg.0.log and found the following error

dbus-error: error connecting to system bus org.freedesktop.DBus.Error.FileNotFound (Failed to connect to socket /run/dbus/system_bus_socket: No such file or directory)

My system is responding to ping (I got the IP by checking the router's DHCP table). However, sshd is my system is not configured to be started on boot so that I can log in to the system using ssh and do further check. I tried enabling this from single user mode and found the following error.

systemctl enable sshd.service
Failed to connect to bus: No such file or directory

From some online tutorial I tried following without any success

chmod 755 /
chmod 755 /bin
chmod 755 /lib

Roughly, my file system ownership and permission is looking perfect to me.

I remember, once I mounted this file system to Fedora 29 and updated it using chroot. This may cause the error. However, I'm unsure whether I used this system after the update or not.

I tried all the above steps once with SELinux enabled and disabled.

I'm not getting how to fix this or how to identify the cause of this problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.