1

So first problem i run into is booting from the live image. But after googling a lot i could figure out something and now i am booting like following:

drivers=nonfree

and adding

systemd.mask=mhwd-live.service

to the boot options.

After doing this i can boot into the live image.

But than if i try to install it it would stuck. So edit the /usr/lib/calamares/modules/mhwdcfg/main.py

From:

def run(self):
    for b in self.bus:
        for id in self.identifier['net']:
                self.configure(b, id)
        for id in self.identifier['video']:
                self.configure(b, id)

    return None

To:

def run(self):
    return None

After doing this i am able to install it with follwoing paritions

drive 1: ssd /dev/nvme0n1p3 at /boot/efi with fat32 and 250mb
/dev/nvme0n1p1 at /swap with linuxswap and 8GiB
/dev/nvme0n1p2 at / with ext4 and 111GiB
drive 2: hdd /dev/sda1 at /home with ntfs and 931.5GiB i had some errors with ext4...

So now it is installed.

After the first startup i am doing update:

sudo pacman -Syyu

after this is done i am rebooting and sometimes it stucks but starts after a hard power off.

Next i tried to install bumblebee without luck and i had to retry...

So i tried added this but i think it is not required in my newest installation i am not using it. /etc/default/grub:

acpi_osi=! acpi_osi='Windows 2009' 

than i did:

sudo update-grub

and reboot

than i will try so install my dual graphics nvida drivers

sudo mhwd -a pci nonfree 0300

But i am stuck at installing the nvidia bumblebee drivers...
Everytime I install them no matter what i am stuck at a complete black screen after reboot and i cant enter with Alt+Ctrl+F1 ...

With the free drivers it is running probably but with really bad performance.

I tried one more thing which is discribed here: howto-set-up-prime-with-nvidia

But after i did everything i am stuck at a black screen again but this time i can access different terminals via CTRL+Alt+F2 ...

0

So i tried again and so booting into an live image first.

than i was doing manjaro-chroot -a updating my kernal to linux51 with mhwd-kernl -i "linux51" and after that i did an **pacman -Syyu i rebooted and it worked <3 lucky me i dont have to install windows.

I got bumblebee running you have to do three things after the step above.

  1. Install Optimus Manager and setting default to Nvidia
  2. Reinstall LightDM
  3. Reinstall Xorg Server

Restart and it should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.