0

I upgraded a headless machine (with openmediavault) from jessie to stretch and after that wake-on-lan stopped working.

I ran down the following checks:

>ethtool eth0
-------------------
Supports Wake-on: g
Wake-on: g

>cat /proc/acpi/wakeup
-------------------------------------------
MMAC      S5    *enabled   pci:0000:00:14.0

>cat /etc/default/halt
---------------------
NETDOWN=no
  • If the machine is up, MagicPackets are received (nc -ul -p 9)
  • I also installed a systemd [email protected] with ethtool -s eth0 wol g but it didn't do any good

Q What do I need to do to get the wake-on-lan back to work?

4
  • hint: are you using NetworkManager?
    – A.B
    Commented May 12, 2019 at 15:05
  • @A.B I installed NetworkManager but it isn't showing any connections. Commented May 12, 2019 at 16:06
  • So it isn't handling eth0? Ok. Else that would have been because NM now handles wake-on-lan and might be disabling it at suspend.
    – A.B
    Commented May 12, 2019 at 16:09
  • 1
    @A.B I made NetworkManager handle eth0, activated wol in NW but the machine is still not waking up. Commented May 14, 2019 at 18:00

1 Answer 1

0

This is not an OS issue at all, because the wake-up should happen from S5 (= power-off). Therefore, only the BIOS settings are of relevance. Since the BIOS settings have been working properly for quite a while I conclude there is a hardware-problem.

Note1 power-on is even instable using the power-button (I double-checked if the switch is defect, which it is not) so it has to be a hardware problem on the motherboard.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .