0

I installed and set-up hotspot using hostapd.

# /etc/init.d/hostapd start
[ ok ] Starting hostapd (via systemctl): hostapd.service.

But when I try to connect my phone to the hotspot, it does not show up on the list. Why is it so? I use Debian on Gnome environment.

This is what my hostapd.conf file looks like:

interface=wlp3s0
ieee80211n=1
channel=6
bridge=br0
ssid=Pauling
wpa=2
country code=IN
wpa_passphrase=password
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIM
rsn_pairwise=CCMP
autht_algs=1
macaddr acl=0
# Change the broadcasted/multicasted keys after this many seconds.
wpa_group_rekey=600
# Change the master key after this many seconds. Master key is used as a     basis
wpa_gmk_rekey=86400

Edit: The error in journalctl -b -u hostapd is:

Starting advanced IEEE 802.11 management: hostapd failed!

That's all.

  • 3
    I don't see a hw_mode; this defaults to 802.11b. Are you sure your phone can see "b" networks? What happens if you add hw_mode=g ? That other thing to verify is that your wl interface name is correct. Does this match what iwconfig says? – Stephen Harris May 12 at 1:08
  • @StephenHarris I tried changing it to both b and g. None of them worked. The interface name is correct. The wlan0 has been changed to wlp3s0 in new kernel or something. – Pauling0304 May 12 at 8:25
  • Does your hardware / driver support hotspot? – Fabby May 12 at 12:31
  • @Fabby Yes, it supports hotspot. I used to do it all the time when I had Ubuntu. – Pauling0304 May 12 at 13:24
  • 1
    BTW, this does not help with your problem, but if you are curious why hostapd reported OK when actually it had failed, I found out why and reported it as a bug in Debian . It already shouldn't happen in the next version of Debian. – sourcejedi May 12 at 15:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.