-2

I've just installed a debian system, and just like the last time 10 years ago, it has b0rked my machine by assuming that my real time/hardware clock was using localtime, despite me not having told it so. It apparently based its decision on the simple existence of a NTFS filesystem on a partition.

I had to edit the /etc/adjtime file by hand and change the LOCAL to UTC.

Is there some simple change that I can do to the ISO "net install" image to prevent it from doing that?

The installer from Debian 9.9.0 is switching directly to a graphical menu upon boot, so there's no command line where I may pass any options to it.

Don't tell me to use the "expert" mode; it may start asking me all kind of expert-level questions I may not have the answer to ;-)

  • How about using timedatectl after installation completed? – Biswapriyo May 11 at 7:18
1

You can preseed clock-setup/utc to skip the auto-configuration (which, as you say, considers the clock to be local time if it finds a Windows, or DOS, system). To do so, the simplest option in your case seems to be to add clock-setup/utc=true to the boot options. Assuming an EFI boot, you can do this in the ISO image by editing boot/grub/grub.cfg to add that setting to the linux line, something like

linux    /install.amd/vmlinuz vga=788 clock-setup/utc=true --- quiet

You’ll need to re-generate the ISO of course.

If you can manage to get the Grub menu before the installer starts, you can edit the kernel boot options there.

Any other preseed option will work too; see the installation manual for details.

(“Expert” mode would also allow you to change the setting.)

  • It turns out that pressing Esc at the boot menu will bring up a command line. I'll have to test if entering install clock-setup/utc=true has the expected effect. – Căcărău May 12 at 8:33
  • also, the grub.cfg from the iso image can be edited in place by taking advantage of its lots of white space, without having to regenerate the iso image -- but I wonder if anybody else will want to do that besides me. – Căcărău May 12 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.