1

I've read another questions related to my issue, but nothing seems to fix mine. So I have an USB ext hard drive (2TB Transcend) that I'm trying to plug it in. It works before like I can use the hard drive. The problem starts yesterday where the device cannot mounted but the notification (from udiskie) tells that the device is appeared. I don't know what happens, like 2 days ago I can use it well, but yesterday it just can't. I'm using Arch Linux.

$ uname -r
5.0.13-arch1-1-ARCH
$ pacman -Q linux
5.0.13.arch1-1

The device is not listed on fdisk and lsblk

$ lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 465.8G  0 disk 
├─sda1   8:1    0  74.3G  0 part /
├─sda2   8:2    0   200M  0 part /boot
├─sda5   8:5    0   7.5G  0 part [SWAP]
└─sda6   8:6    0 383.8G  0 part /home
sr0     11:0    1  1024M  0 rom  
# fdisk -l
Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Disk model: ST500DM002-1BD14
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 81A45AD8-92E8-44C0-8032-EF3D351997DF

Device         Start       End   Sectors   Size Type
/dev/sda1     411648 156252159 155840512  74.3G Linux filesystem
/dev/sda2       2048    411647    409600   200M Linux filesystem
/dev/sda5  156252160 171874303  15622144   7.5G Linux swap
/dev/sda6  171876352 976771071 804894720 383.8G Linux filesystem

Partition table entries are not in disk order.

That is my system hard drive. But the ext hard drive is detected on lsusb

$ lsusb
Bus 002 Device 003: ID 04f2:1053 Chicony Electronics Co., Ltd 
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 005: ID 8564:7000 Transcend Information, Inc.               // This one!
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

And the dmesg tells that it was trying to read the drive but timed out.

$ dmesg | tail -n 20
[ 1832.986654] usb 1-1.2: USB disconnect, device number 4        // This part I was unplugged the drive and replugged it in
[ 1833.084639] usb 1-1.2: new high-speed USB device number 5 using ehci-pci
[ 1833.240367] usb 1-1.2: New USB device found, idVendor=8564, idProduct=7000, bcdDevice=80.00
[ 1833.240371] usb 1-1.2: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[ 1833.240373] usb 1-1.2: Product: StoreJet Transcend
[ 1833.240375] usb 1-1.2: Manufacturer: StoreJet Transcend
[ 1833.240376] usb 1-1.2: SerialNumber: ÿÿÿÿtSroJeteT arsnec
[ 1833.240878] usb-storage 1-1.2:1.0: USB Mass Storage device detected
[ 1833.241118] scsi host4: usb-storage 1-1.2:1.0
[ 1834.259269] scsi 4:0:0:0: Direct-Access     StoreJet Transcend        0    PQ: 0 ANSI: 6
[ 1834.260301] sd 4:0:0:0: [sdb] Very big device. Trying to use READ CAPACITY(16).
[ 1834.260795] sd 4:0:0:0: [sdb] Unsupported sector size 14712.
[ 1834.260802] sd 4:0:0:0: [sdb] 0 512-byte logical blocks: (0 B/0 B)
[ 1834.260806] sd 4:0:0:0: [sdb] 14712-byte physical blocks
[ 1834.261883] sd 4:0:0:0: [sdb] Write Protect is off
[ 1834.261888] sd 4:0:0:0: [sdb] Mode Sense: 43 00 00 00
[ 1834.262881] sd 4:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 1834.264261] sd 4:0:0:0: [sdb] Unsupported sector size 14712.
[ 1834.266260] sd 4:0:0:0: [sdb] Attached SCSI disk
[ 1864.287693] sd 4:0:0:0: timing out command, waited 30s

It says Very big device. Trying to use READ CAPACITY(16). and Unsupported sector size 14712.. What's that mean? How can I at least backup the data in it?

2

USB disks are controlled using SCSI commands, or Command Descriptor Blocks (CDBs).

Initially the kernel makes the disk capacity query using a 10-byte CDB, which is the older and more widely supported form. But if the answer indicates the disk size does not fit in the old response format, the kernel logs Very big device. Trying to use READ CAPACITY(16) and retries the operation using a newer command that uses a 16-byte CDB, which can handle huge disk sizes.

The message Unsupported sector size 14712 is a problem. The Linux kernel is prepared to accept sector sizes of 512, 1024, 2048 or 4096 bytes. The value of 14712 bytes does not fit any of these values. When an unsupported size is encountered, the SCSI disk driver will set the disk capacity value to 0, to disallow accessing the device until the sector size issue has been fixed somehow (probably using a vendor-specific tool to reformat the disk to use a different sector size).

This strange sector size might be a bogus response caused by the drive not getting enough power (as suggested by Alejandro Galván Gómez in another answer). In that case, using a different USB cable or port might help.

It might also be an indication that the disk has failed. In that case it's too late to think about taking backups now, unless you're lucky and the disk manages to start up correctly one more time.

| improve this answer | |
  • Do you reckon removing the disk from the enclosure and connecting it directly to a SATA port would be a good troubleshooting step? – Henrique de Sousa Mar 31 at 15:15
  • If the external disk is under warranty, it might be easier to not mess with it an just get a warranty replacement. But if it's out of warranty (or you don't care), then it's probably worth a try. – telcoM Mar 31 at 16:05
1

I'd been having the same problem as you with an external WD hdd. After days of googling around (without answers) I realized I had changed the cable (an extension I used to reach my USB port). I tried connecting it directly with its original cable and it worked. Then I tried a few new cable extensions until I found one that did the trick.

That is if you're trying to mount it using the same USB port you connected it in before.

It is also an energy consumption problem. I tried it in other USB ports and got it listed in lsusb and detected in dmesg, but not in fdisk. I found my answer here: https://raspberrypi.stackexchange.com/questions/9279/harddrive-detected-as-13fd160e-initio-corporation-instead-of-10581010-western

| improve this answer | |
0

It needs to be partitioned to be usable. Your disk would be viewable with(as root):

fdisk -l /dev/sdb

...if dmesg didn't indicate there might be something wrong with it. But if you do get meaningful output from that command, you should be able to partition it and format it.

| improve this answer | |
  • the comand returns: fdisk: cannot open /dev/sdb: No such file directory. Edit: I've been using this hdd for 3 months, I got my data there, and this issue just happened yesterday. – Gregorio May 11 '19 at 4:12
  • Ugh, it sounds like you might have a failed disk. – bahua May 11 '19 at 4:42
  • any suggestions on how can I back up the data? – Gregorio May 11 '19 at 5:47
  • That's what backups are for: saving the data so things like hardware failure don't cause data loss. If the disk is failed, then the word now is, "recovery." You first need to make sure it really is failed, and if it is, you can pay a data recovery company a lot of money to disassemble the platters and reconstitute the working parts of the disk to attempt to copy the data off it. – bahua May 11 '19 at 6:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.