0

I sshfs'd into a remote server with standard syntax:

sshfs ubuntu@server.somewhere.com:/home/ubuntu/ ./myfolder -o IdentityFile=~/.ssh/my-private-key.pem -o allow_other

Everything worked fine. The file structure there was

/all/data/workdata

Then, the remote server changed the file structure and reset the machine. The new structure is now

/all/new/data/workdata

I unmounted with

sudo umount -l myfolder

then remounted. Now I can't access anything. The "old" folder structure is retained for me, and when I am in /all/, dir still shows "data". If I try to cd there, I get "no such directory" (also if I try to cd into the invisible "new"). I've tried -o cache_timeout=0 -o workaround=rename. I can sshfs into other remote servers normally. What is going on? How can I get into the server?

  • How is /home/ubuntu (the folder you mount) on the server related to /all/...? You might want to add the output of ls -alh /all on the server side and the output of ls -alh ./myfolder on your local machine. – Thomas May 11 at 7:55
  • /home/ubuntu is where /all/ is located after the file system of the server was changed. The ls -alh /all output from the local machine shows all in red text, with an arrow pointing to white, blinking /data/workdata. ls -alh from the sever shows /all/ in blue text. – Zwentibold May 12 at 16:14
  • It still sounds a bit confusing for me how /home/ubuntu and /all folder are connected as these are completely different locations in the filesystem and you are trying to mount /home/ubuntu from the server. I think best would be you talk to the admin of the server to tackle your problems. – Thomas May 12 at 16:52
  • The white, blinking all folder indicates a dead symbolic link which needs to be updated. From the information you provided it still does not relate to the paths you mentioned in your question. – Thomas May 12 at 17:03
  • It turns out I just need to use -o follow_symlinks. Now everything is working as expected. Thanks for your help! – Zwentibold May 12 at 17:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.