1

I've just installed Fedora 30 (GNOME desktop) on my machine with french apple aluminum keyboard. But "@" key is not correctly mapped. It should be at left of "1" key but instead I have "<". And instead of having "<" at right of left shift key, I, of course, have "@".

How to remapp or have a correct layout for this keyboard ?

What I did so far :

1/ I selected correct language (Français(France)) and correct keyboard (Français (Macintosh)) in gnome settings (as I did in previous Fedora installs). And when I click on display keyboard layout, I see the correct layout.

enter image description here

$ localectl status
  System Locale: LANG=fr_FR.UTF-8
  VC Keymap: fr-mac
  X11 Layout: fr,fr,fr
  X11 Variant: mac,,oss

2/

# sudo localectl set-x11-keymap fr apple mac
$ localectl status
  System Locale: LANG=fr_FR.UTF-8
  VC Keymap: fr-mac
  X11 Layout: fr
  X11 Model: apple
  X11 Variant: mac

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.