I had Fedora 17 in a primary partition. Yesterday I installed Ubuntu in an extended partition, and I can't see Fedora in grub, so I tried update-grub2 but it doesn't recognise Fedora being present, even if the Fedora partition is mounted. So I tried to re-install grub from live USB but it did not work either.

How to bring back my Fedora? I don't want to re-install Fedora in the other partition.

Output of fdisk -l

root@phanindra-VPCCW25FN:/home/phanindra# fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000afaf9

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048    46139391    23068672   83  Linux
/dev/sda2        46141438    83888127    18873345    5  Extended
/dev/sda3        83888128   207808511    61960192   83  Linux
/dev/sda4       207808512   625141759   208666624   83  Linux
/dev/sda5        46141440    52432895     3145728   82  Linux swap / Solaris
/dev/sda6        52434944    83888127    15726592   83  Linux

/dev/sda6 has the current Ubuntu and /dev/sda1 has Fedora. Is there any other option without installing super grub?

  • Edit your question and add the output of sudo fdisk -l.
    – jokerdino
    Commented Oct 14, 2012 at 7:56
  • updated the question qith fdisk -l output
    – pahnin
    Commented Oct 14, 2012 at 10:33
  • I think you have to be more clear about what exactly you're trying to achieve and where you got so far, How the partitions are formatted and what file systems are being used. I'm curious how and especially why you attempted to reinstall GRUB. I'm afraid most of the answers so far are plain guesswork, probably not useful at all. Commented Jul 13, 2014 at 10:31

5 Answers 5


Mount the Fedora partition. Go to the /mount/point/boot/grub/grub.cfg and then get the things which says Fedora and edit you own /boot/grub/grub.cfg.


You can do chroot and use Fedora's installation. Something like:

$ mount /dev /fedora/partition/mount/dev -bind
$ mount /sys /fedora/partition/mount/sys -bind
$ mount /proc /fedora/partition/mount/proc -bind
$ cd /fedora/partiton/mount/
$ chroot .

Then reload your grub using your Fedora chroot inside the Ubuntu.


login to ubuntu and try this method

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install -y boot-repair

After a few seconds, Boot Repair's main window will open. Click on Recommended repair. enter image description here

  1. Log in to Ubuntu
  2. $ grub-update

All done!

  • 1
    did it already, it wont work
    – pahnin
    Commented Oct 14, 2012 at 10:31
  • hmm.. strange it till 10.10 it used to auto detect... check if you have "os-prober" installed... or you can try to reinstall the grub once more.
    – rho
    Commented Oct 15, 2012 at 4:49

Try Super Grub 2

It should automatically find all the OSes!

  • 1
    is super grub disk 2 for broken system or for normal use?
    – pahnin
    Commented Oct 14, 2012 at 10:37
  • 1
    It is basically built up to have a back up in case u screw with your system while trying new OS and loose one/more OS being enlisted in ur grub. So your problem seems similar. you can give a try! Commented Oct 16, 2012 at 2:35

I ran into this recently, with the same scenario. I ended up canceling from the Ubuntu Grub menu and typed exit to reboot and then it brought me into the Fedora boot menu where I could boot Fedora or Ubuntu.

I used to get the Fedora menu every time until I recently, when I ran Ubuntu again and did some updates, which broke it.

Going to try some of the suggestions above now to fix this long term.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .