0

When I run airodump-ng to scan Wi-Fis around me, I get no output, like there's nothing around me.

I have a Qualcomm Atheros QCA9377 adapter that's integrated in my laptop (Dell Inspiron 15) and i'm running Kali Linux 64 2019.1

here's the airmon-ng output:

airmon-ng start wlan0

Found 3 processes that could cause trouble.
Kill them using 'airmon-ng check kill' before putting
the card in monitor mode, they will interfere by changing channels
and sometimes putting the interface back in managed mode

  PID Name
  550 NetworkManager
  602 wpa_supplicant
 2069 dhclient

PHY Interface   Driver      Chipset

phy0    wlan0       ath10k_pci  Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)

        (mac80211 monitor mode vif enabled for [phy0]wlan0 on [phy0]wlan0mon)
        (mac80211 station mode vif disabled for [phy0]wlan0)

i have tried airmon-ng check kill but it didn't work, when i run airodump-ng, here's what i get:

CH 12 ][ Elapsed: 12 s ][ 2019-05-09 19:23                                    

 BSSID              PWR  Beacons    #Data, #/s  CH  MB   ENC  CIPHER AUTH ESSID


 BSSID              STATION            PWR   Rate    Lost    Frames  Probe 

with channels switching, i have tried using 1 specific channel yet i found not ports with this solution either. I have also noticed some error messages when i boot linux related to the network driver:

ath10k_pci 0000:02:00.0: firmware: failed to load ath10k/pre-cal-pci-0000:02:00.0.bin (-2)
firmware_class: See http://wiki.debian.org/Firmware for information about missing firmware
ath10k_pci 0000:02:00.0: firmware: failed to load ath10k/cal-pci-0000:02:00.0.bin(-2)
ath10k_pci 0000:02:00.0: firmware: failed to load ath10/QCA9377/hw1.0/firmware-6.bin (-2)

I also confirmed that my network adapter supports monitor mode using iw list and monitor mode appears in the list:

Supported interface modes:
         * IBSS
         * managed
         * AP
         * monitor
         * mesh point
         * P2P-client
         * P2P-GO
         * P2P-device
  • Reading this, I'm curious to see more about what exactly happened with "airmon-ng check kill ". Did the processes go away? Did you get any errors or output at all? – Jeff Schaller May 10 at 13:44
  • the processes simply go away, no output – Amosimo May 12 at 18:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.