0

I am currently trying to compile libX11 version 1.0.0 and during the configure process this error message shows up:

checking for BIGREQS... configure: error: Package requirements (bigreqsproto) were not met:

I need to find the package (source package) that provides whatever the configure looks for it. The problem is that I am not being able to do so. The INSTALL and the README files does not indicate and the

configure --help

also does not. I looked for something with a name similar to "BIGREQS" on this link: https://www.x.org/releases/individual/lib/ but was not able to find anything remotely similar (at least I didn't note it)

So I would eagerly thanks anyone who knows what is the source package that I require to satisfy this dependency. Many thanks.

1 Answer 1

2

That's xorgproto (mostly definitions, not a "library" per se).

3
  • Thanks for the help. However, although your link worked for the configure part, it does not for the compiling part. This is the error message that appears: make[2]: Leaving directory `/media/34GB/Arquivos-de-Programas-Linux/libX11-1.0.3/src/util' ../src/util/makekeys < /media/34GB/Arquivos-de-Programas-Linux/Xorgproto-2018.1/include/X11/keysymdef.h > ks_tables_h /bin/bash: line 1: 12155 Floating point exception../src/util/makekeys < /media/34GB/Arquivos-de-Programas-Linux/Xorgproto-2018.1/include/X11/keysymdef.h > ks_tables_h make[1]: *** [ks_tables.h] Error 136 May 13, 2019 at 14:45
  • So I wonder if you do know where I can find an older version (it was xproto before, right?) that may not produce this error. May 13, 2019 at 14:47
  • The link is for the source repository, which is as complete as you'll be able to find. May 13, 2019 at 19:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .