1

I'm trying to to install libgsf-1-114 package which according to the packages.ubuntu the latest version is 1.14.45-1.
Currently I have version 1.14.36-1:

apt list libgsf-1-114
Listing... Done
libgsf-1-114/xenial,now 1.14.36-1 amd64 [installed,automatic]

But if I try to upgrade, I get:

sudo apt-get -s upgrade libgsf-1-114 | grep libgsf
libgsf-1-114 is already the newest version (1.14.36-1).
libgsf-1-114 set to manually installed.

I've tried setting it to auto, but it keeps saying its manually installed (if that makes any difference)

sudo apt-mark auto libgsf-1-114
libgsf-1-114 was already set to automatically installed.

I actually want to upgrade to a specific version and not to the latest but it looks like the package manager just can't find a newer version

  • What version of Ubuntu are you on? That is the latest version for 16.04 (Xenial). – kemotep May 8 at 17:56
  • Thank you @kemotep, I am using Ubuntu 16.04 (inside Windows), where can I see the latest package version per ubuntu version? – SagiLow May 8 at 18:03
  • I am using Ubuntu 16.04 (inside Windows),: Is it WSL? – Kulfy May 8 at 18:47
  • @Kulfy yes it is.. – SagiLow May 9 at 7:48
3

For your version of Ubuntu (16.04), that is the latest package version. As per your own link, if you want that particular version, you need to upgrade to:

disco (19.04) (libs): Structured File Library - runtime version

If you want the latest package version for your version of Ubuntu, use this link:

https://packages.ubuntu.com/search?keywords=szPackageName&searchon=names&suite=xenial&section=all

Where you change szPackageName by the package you're looking for.

  • 1
    got it. thank you – SagiLow May 8 at 18:05
  • 1
    @SagiLow Updated to include your last comment. – Fabby May 8 at 18:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.