1

I am on Arch Linux Raspberry Pi. I have a Ruby script that blinks LED light connected to GPIO pin 7 (https://github.com/Souravgoswami/others/blob/master/ActivityBlink/activity_blink.rb). There's no problem with that.

But to start that script as root at boot, I have created a systemd service without much understanding:

[Unit]
Description=A simple script to send GPIO output based on storage device activity.

[Service]
Type=simple
ExecStart=!!/usr/bin/activity_blink
ExecReload=/bin/kill -HUP $MAINPID
KillMode=process
Restart=on-failure
RestartSec=3
User=root
Group=root

[Install]
WantedBy=multi-user.target

Now I enabled the service: sudo systemctl enable activity_blink

After that, on boot, it works fine, but at the time of shutting down the system, it keeps saying:

[*** ] A stop job is running for A simple script to send GPIO output based on storage device activity. (15s / 5min 30s).

What's wrong with the service script? How can I change the behaviour without changing anything from system.conf?

  • Why do you think something is wrong? – Ortomala Lokni May 13 at 21:50
  • It always says a stop job is running ... And it takes more than 5 minutes to shutdown the system. That's a huge problem for me! – S.Goswami May 14 at 10:22
  • 1
    Try to define ExecStop=... and stop yourelf activity_blink. – Ortomala Lokni May 14 at 11:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.