0

I can't seem get a windows guest installed on virt-manager. When I start the machine before the install cd loads I get a blue screen with code SYSTEM THREAD EXCEPTION NOT HANDLED.

Here's the logfile

2019-05-08 03:10:12.923+0000: starting up libvirt version: 4.0.0, package: 1ubuntu8.8 (Marc Deslauriers <marc.deslauriers@ubuntu.com> Wed, 13 Mar 2019 08:09:33 -0400), qemu version: 2.11.1(Debian 1:2.11+dfsg-1ubuntu7.12), hostname: hex
LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin QEMU_AUDIO_DRV=spice /usr/bin/kvm-spice -name guest=win10,debug-threads=on -S -object secret,id=masterKey0,format=raw,file=/var/lib/libvirt/qemu/domain-12-win10/master-key.aes -machine pc-i440fx-bionic,accel=kvm,usb=off,vmport=off,dump-guest-core=off -cpu EPYC-IBPB,hv_time,hv_relaxed,hv_vapic,hv_spinlocks=0x1fff -m 4096 -realtime mlock=off -smp 1,sockets=1,cores=1,threads=1 -uuid 55c34055-9a9c-4638-9880-d0bc5be0b4c5 -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/domain-12-win10/monitor.sock,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -global kvm-pit.lost_tick_policy=delay -no-hpet -no-reboot -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1 -boot strict=on -device ich9-usb-ehci1,id=usb,bus=pci.0,addr=0x5.0x7 -device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pci.0,multifunction=on,addr=0x5 -device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=pci.0,addr=0x5.0x1 -device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=pci.0,addr=0x5.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x6 -drive file=/var/lib/libvirt/images/win10.qcow2,format=qcow2,if=none,id=drive-ide0-0-0 -device ide-hd,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=2 -drive file=/home/stibbons/Downloads/Win10_1809Oct_v2_English_x64.iso,format=raw,if=none,id=drive-ide0-0-1,readonly=on -device ide-cd,bus=ide.0,unit=1,drive=drive-ide0-0-1,id=ide0-0-1,bootindex=1 -netdev tap,fd=26,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:5d:0c:f2,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel0,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 -device usb-tablet,id=input0,bus=usb.0,port=1 -spice port=5900,addr=127.0.0.1,disable-ticketing,image-compression=off,seamless-migration=on -device qxl-vga,id=video0,ram_size=67108864,vram_size=67108864,vram64_size_mb=0,vgamem_mb=16,max_outputs=1,bus=pci.0,addr=0x2 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -chardev spicevmc,id=charredir0,name=usbredir -device usb-redir,chardev=charredir0,id=redir0,bus=usb.0,port=2 -chardev spicevmc,id=charredir1,name=usbredir -device usb-redir,chardev=charredir1,id=redir1,bus=usb.0,port=3 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7 -msg timestamp=on
2019-05-08T03:10:12.955232Z qemu-system-x86_64: -chardev pty,id=charserial0: char device redirected to /dev/pts/2 (label charserial0)
main_channel_link: add main channel client
red_qxl_set_cursor_peer:
inputs_connect: inputs channel client create
red_channel_client_disconnect: rcc=0x55d1aadfdd10 (channel=0x55d1a9a1aaf0 type=5 id=0)
red_channel_client_disconnect: rcc=0x55d1a9a95f20 (channel=0x55d1a9a1abb0 type=6 id=0)
red_channel_client_disconnect: rcc=0x55d1aa953300 (channel=0x55d1aabe7150 type=9 id=0)
red_channel_client_disconnect: rcc=0x55d1aa8ae780 (channel=0x55d1aabe7220 type=9 id=1)
2019-05-08 03:10:58.144+0000: shutting down, reason=shutdown
2019-05-08 03:10:58.982+0000: starting up libvirt version: 4.0.0, package: 1ubuntu8.8 (Marc Deslauriers <marc.deslauriers@ubuntu.com> Wed, 13 Mar 2019 08:09:33 -0400), qemu version: 2.11.1(Debian 1:2.11+dfsg-1ubuntu7.12), hostname: hex
LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin QEMU_AUDIO_DRV=spice /usr/bin/kvm-spice -name guest=win10,debug-threads=on -S -object secret,id=masterKey0,format=raw,file=/var/lib/libvirt/qemu/domain-13-win10/master-key.aes -machine pc-i440fx-bionic,accel=kvm,usb=off,vmport=off,dump-guest-core=off -cpu EPYC-IBPB,hv_time,hv_relaxed,hv_vapic,hv_spinlocks=0x1fff -m 4096 -realtime mlock=off -smp 1,sockets=1,cores=1,threads=1 -uuid 55c34055-9a9c-4638-9880-d0bc5be0b4c5 -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/domain-13-win10/monitor.sock,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -global kvm-pit.lost_tick_policy=delay -no-hpet -no-shutdown -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1 -boot strict=on -device ich9-usb-ehci1,id=usb,bus=pci.0,addr=0x5.0x7 -device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pci.0,multifunction=on,addr=0x5 -device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=pci.0,addr=0x5.0x1 -device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=pci.0,addr=0x5.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x6 -drive file=/var/lib/libvirt/images/win10.qcow2,format=qcow2,if=none,id=drive-ide0-0-0 -device ide-hd,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -drive file=/home/stibbons/Downloads/Win10_1809Oct_v2_English_x64.iso,format=raw,if=none,id=drive-ide0-0-1,readonly=on -device ide-cd,bus=ide.0,unit=1,drive=drive-ide0-0-1,id=ide0-0-1 -netdev tap,fd=26,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:5d:0c:f2,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel0,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 -device usb-tablet,id=input0,bus=usb.0,port=1 -spice port=5900,addr=127.0.0.1,disable-ticketing,image-compression=off,seamless-migration=on -device qxl-vga,id=video0,ram_size=67108864,vram_size=67108864,vram64_size_mb=0,vgamem_mb=16,max_outputs=1,bus=pci.0,addr=0x2 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -chardev spicevmc,id=charredir0,name=usbredir -device usb-redir,chardev=charredir0,id=redir0,bus=usb.0,port=2 -chardev spicevmc,id=charredir1,name=usbredir -device usb-redir,chardev=charredir1,id=redir1,bus=usb.0,port=3 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7 -msg timestamp=on
2019-05-08T03:10:59.014727Z qemu-system-x86_64: -chardev pty,id=charserial0: char device redirected to /dev/pts/2 (label charserial0)
main_channel_link: add main channel client
red_qxl_set_cursor_peer:
inputs_connect: inputs channel client create

Any idea what's happening?

Edit: Should probably add more system information.

OS: KDE Neon (based on Ubuntu 18.04)
Kernel: 4.18.0
CPU: Threadripper 1950x
Motherboard: asus zenith extreme
Graphics: GTX 1080

  • @MichaelHampton I did. Three in total actually. – RedHatter May 8 at 4:29
  • Did you try more CPU/RAM and a combination of UEFI/BIOS & Q35/I440x? – FreeSoftwareServers May 8 at 5:42
0

The obvious problems I see here:

The usual cause of this is a corrupt ISO image, but you seem to have downloaded it more than once...

You used the i440fx (PC) machine type, which emulates the hardware of a 1996-era PC. Windows 10 guests should use the Q35 machine type. If available on your system, (sudo apt install ovmf) you should also consider using UEFI boot.

You gave the guest only one virtual CPU. This might or might not be the immediate cause of the problem, but it will come back to bite you later. Give it at least two vCPUs.

  • I changed the chipset to Q35 and enabled UEFI which required changing the storage interface to SATA (was set to IDE by default) but nothing changed, I still get a blue screen when the install cd loads. – RedHatter May 8 at 5:08
  • @RedHatter Delete the VM and start over. Just changing the machine-type doesn't work. – Michael Hampton May 8 at 14:12
  • Sorry if I wasn't clear, I did recreate the VM. I tried Q35 + UEFI, Q35 + BIOS, and i440fx + UEFI. – RedHatter May 9 at 0:45
  • @RedHatter Really? That's rather odd. Are you quite sure your ISO isn't corrupt? I don't see any other issues here. – Michael Hampton May 9 at 1:35
0

I think the problem was my kernel version. I installed Ubuntu 19.04 which runs kernel 5.0.0 and everything is working fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.