1

I have a custom built Windows 10 desktop that I am considering putting Linux on. Since I use CentOS on my file server, my first choice was to also use CentOS on the desktop. However, when I tried to install CentOS 7, the installer didn't even load, causing some errors with Nouveau. I'm using a GeForce GTX 1070 Ti.

I tried putting a fresh CentOS installer on the USB stick I was using; no luck. I tried using a different port; no luck there either. I tried unplugging all unnecessary USB devices (only leaving the keyboard, mouse, and USB stick plugged in), and that didn't work either.

The messages I got on the screen go as follows:

[  8.285997] nouveau 0000:01:00.0: gr: 409000 - stat 000e7500 00000000 00000209 00000000
[  8.286005] nouveau 0000:01:00.0: gr: 409000 - stat 00011900 00000000 00000018 00000000
[  8.286010] nouveau 0000:01:00.0: gr: 502000 - done 00000300
[  8.286019] nouveau 0000:01:00.0: gr: 502000 - stat 00000000 00000000 00000001 00000000
[  8.286029] nouveau 0000:0a:00.0: gr: 502000 - stat 00080425 00000000 00000000 00000000
[  8.286034] nouveau 0000:01:00.0: gr: 50a000 - done 00000300
[  8.286043] nouveau 0000:01:00.0: gr: 50a000 - stat 00000000 00000000 00000001 00000000
[  8.286053] nouveau 0000:01:00.0: gr: 50a000 - stat 00080436 00000000 00000000 00000000
[  8.286058] nouveau 0000:01:00.0: gr: 512000 - done 00000300
[  8.286066] nouveau 0000:01:00.0: gr: 512000 - stat 00000000 00000000 00000001 00000000
[  8.286075] nouveau 0000:01:00.0: gr: 512000 - stat 00080447 00000000 00000000 00000000
[  8.286079] nouveau 0000:01:00.0: gr: 51a000 - done 00000300
[  8.286102] nouveau 0000:01:00.0: gr: 51a000 - stat 00000000 00000000 00000001 00000000
[  8.286111] nouveau 0000:01:00.0: gr: 51a000 - stat 00080458 00000000 00000000 00000000
[137.192886] dracut-initqueue[1091]: Warning: dracut-initqueue timeout - starting timeout scripts

The message at [137.192886] repeats about every half second through [200.255076], which is followed by the following:

[200.255748] dracut-initqueue[1091]: Warning: Could not boot.
[200.291461] dracut-initqueue[1091]: Warning: /dev/root does not exist
Starting Dracut Emergency Shell...
Warning: /dev/root does not exist

Generating "/run/initramfs/rdsosreport.txt"

Entering emergency mode. Exit the shell to continue.
Type "journalctl" to view system logs.
You might want to save "/run/initramfs/rdsosreport.txt" to a USB stick or /boot
after mounting them and attach it to a bug report.

dracut:/#

Finally, I tried putting the Ubuntu 18.04 installer on the same flash drive and running that. That worked. Still, I would rather use CentOS for the disk management capabilities. Is there a way I can get CentOS to install? Or is my computer simply incompatible with that distro?

EDIT: The disk management capabilities in question relate to LVM. I know that the CentOS installer allows me to set up LVM, and I know that the Ubuntu installer does not (well, at least for desktops; haven't tried the server installer). Thus, if CentOS is incompatible, maybe another distro might work?

  • Perhaps I could suggest Fedora fedoramagazine.org/announcing-fedora-30 , as it's much more similar to CentOS? Alternatively, if you would provide the error messages, we could work on CentOS. Please click edit and add the error data to the original question; please don't click [Add Comment] as comments get hidden when new comments arrive. – K7AAY May 7 at 18:42
  • 1
    @K7AAY , I will put in the error data as soon as i get the chance. I'll let you know when i do! – PSDuckie May 7 at 18:54
  • @K7AAY, the messages I got are posted in the question. – PSDuckie May 7 at 23:36
0

If those errors happened at installation time, they suggests the installer initramfs failed to load the second-stage squashfs image from the installation media. That suggests some sort of storage hardware support problem: perhaps CentOS installation media does not have a new enough kernel to correctly recognize your USB3 controller?

In general, on a pretty new desktop hardware, I'd expect Ubuntu to have a higher probability of installation success than CentOS, as Ubuntu is more strongly desktop-oriented and has a faster life-cycle than CentOS.

Ubuntu definitely has LVM support, but it may require an "advanced installation" to use it on the system disk: see official Ubuntu documentation here. Once installed, the command-line use of LVM is identical in CentOS and Ubuntu. I have no idea about the state of any GUI-based LVM tools; I've never used them with LVM.

  • My plan is to use my 250GB SSD for /boot and put the other three drives (two 3TB and one 4TB) into an LVM pool at /. I'll have to try doing that on Ubuntu at some point! – PSDuckie May 8 at 17:16
0

Using centos on a work server, I have found I need in server bios, while it is EFI, to set vga priority = onboard to use the motherboard vga when booting the centos 7.6-1810 dvd otherwise i get black screen when i expect that first install gui screen; Using motherboard VGA I can get through the install then when finished do a systemctl set-default multi-user.target then upon reboot in bios set vga priority = offboard and then successfully boot into the installed linux os but at runlevel 3 where it is functional and then i can install Nvidia drivers followed by systemctl set-default graphical.target.

I usually leave default as multi-user.target and then manually always do a systemctl isolate graphical.target each time after boot; I find this a safe and almost guaranteed way to successfully boot or at least see what a boot problem might be... for a work environment.

You did not mention your motherboard make/model, I suspect that's where your problem really lies and not so much with the gtx1070. I have a gtx970 on an asrock uefi mobo at home, I had no problem installing centos through the displayport from graphics card to 2560x1440. Look in your bios/uefi and look for CSM (compatibility support module). there are also some other guys in there (forget exact name) but if they are set to UEFI ONLY then set them to LEGACY especially if it's PCIE graphics related. And then if you have onboard graphics, you could always enable that and remove the nvidia graphics card just for the install, then follow my procedure above to move back to using monitor connected to your gtx1070.

I had a similar problem years ago, with Suse on a previous Asrock mobo with same gtx970 I still have when UEFI just hit the scene; was very problematic however i could install SLES on the same mobo with gtx970 but I had to set things to legacy in bios (whereas windows 7 at the time had no problem with everything as uefi)

  • It definitely could be that. It might make sense for me to just try another distro instead of messing with the BIOS though; messing with the BIOS is going to be a last resort for me. – PSDuckie May 8 at 2:10
  • don't be afraid of bios, you should become familiar with it. Change one thing at a time, write it down on paper if you have to, to go back to default settings if few simple changes at a time don't do it.. – ron May 8 at 2:14
  • Oh, I am familiar with it. That's why I'm trying to avoid it if I can. – PSDuckie May 8 at 2:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.