1

I have a networked printer with a fixed IP address. When I try to print to the printer, usually it works, but sometimes I get a "no route to host" error.

Does this mean the printer is resetting itself or disconnecting from the network and reconnecting spontaneously?

Notes:

(1) The network is a single subnet with wired connections and fixed (static) IP addresses.

(2) There is nothing wrong with the network connectivity of the client and it can connect just fine with the rest of the subnet and the internet at large.

(3) The linux machine (the client) is printing by connecting to the printer on port 9100, sending a PJL file to it, then closing the connection. Usually it works fine, but every so often, the attempt to connect gets a "no route to host" error. In this case, just trying again usually works.

(4) I have not tried to have a secondary device connect to the printer at the same time the original client tried. This would be tricky to do, because as I said, usually the printer works. The error only happens intermittently.

(5) The printer is an HP M605dn

One possible explanation is that the problem is being caused by UPnP. I have read that many routers now use UPnP and that devices like printers sometimes do not interact with the UPnP correctly so that the router might be cutting it off. If this is the case, then the question is how to verify/diagnose that it is indeed the problem.

One oddity is that when I ping the printer from the client, it always works but I get interspersed "Redirect from Host" ping packets. In other words the router has 5 addresses 123.456.789.012-17 or whatever, and there are four ports on the router. So, the first one is like 123.456.789.012 and the second one is 123.456.789.013, etc. The client is plugged into one and the printer into another. However, when the local subnet is resolved, then these addresses are converted into local addresses like 10.1.10.90 and 10.1.10.91. When I print, I use these local addresses and the printer thinks its own address is of the local type. However, when I ping, usually the local address is used, but when the ping first starts some of the packets get redirected from the assigned addresses. This could mean nothing important or maybe it is significant, I don't know.

closed as too broad by Rui F Ribeiro, Mr Shunz, Stephen Kitt, Kiwy, Fabby May 10 at 10:28

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • This question is asking people to guess something they cannot possibly know. – Rui F Ribeiro May 7 at 13:48
  • @roaima I have done that. – Tyler Durden May 8 at 11:47
  • 1
    Why in the world would you use public IP on a local network. Please put your real private network IP. If your domain name are solve to public IP change that right now. If you have issue with this I would say that your printer is solve as public ip going out through router and then translated as private IP to re enter the private network. It's very broad without full knowledge of your network topology, addresses and DNS. – Kiwy May 10 at 9:49

Browse other questions tagged or ask your own question.