2

I need to use the title (-title/-T) for a terminal app called cmus in rxvt. But, When I am running

urxvt -e cmus -T "cmus"

It opens and closes. cmus is a music player and it changes the title dynamically depending on the track so I'm finding it hard to bind some key to bring it forward. Is there any other way to affix it's title?

  • 2
    Does superuser.com/questions/308650/… help? Basically stop the app from changing the title. – Stephen Harris May 6 '19 at 2:42
  • 1
    Yes, you should configure cmus to stop changing the title. There's no way to disable the \e]2;title\a escape in rxvt (or to selectively disable terminal escapes, except for those considered "insecure", which the set_title apparently is not). – pizdelect May 6 '19 at 2:51
  • The :set set_term_title=false can do this, is there any configrc file for cmus where I can put this in? – Ritajit Kundu May 6 '19 at 3:00
  • I found the rc file's location in the man pages. It is located here ~/.config/cmus/rc – Ritajit Kundu May 6 '19 at 3:17
2

The rc file for cmus is located at ~/.config/cmus/rc. If it is not there create one. In there put

fset set_term_title=false

This will stop cmus from changing the title dynamically.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.