0

I am trying to connect to the internet on a blade server running RHEL7 with Gnome. I should preface with stating I have effectively no experience with RHEL.

I can connect to the blade OS through iLO 4 over DHCP and one ethernet connection going to the active OA. However, once in Gnome, no internet connection is available. The wired connection image in the top right does not appear. I don't know if there's a driver or service pack I'll need or if I should have another connection going to one of the switches on the enclosure or where to begin. But I will be extremely grateful for any suggestions!

Enclosure: HP c7000 Blade: (1) HP ProLiant BL465c Gen8 OS: RHEL Server 7.6 + Gnome GUI

enter image description here

enter image description here


EDIT: systemctl status NetworkManager outputs that it is active:

enter image description here


EDIT2: Tried starting fresh with CentOS, requesting guidance on setting Network and Hostname at first boot:

enter image description here


EDIT3:

nmcli d shows there is a Bridge, but not ethernet: enter image description here

  • 1
    If your blade server configured to have an ethernet connection through the enclosure to the external network? iLO is not on a 'normal' network connection for the active operating system; it is typically a separate, dedicated interface for connecting to the IPMI hardware. Execute lspci | grep -i ethernet in Gnome-Terminal and identify your network interface hardware that RHEL recognizes. You may have to install HPE drivers for the blade network devices. – 0xSheepdog May 5 at 23:05
  • Thank you for the quick reply! I do not know if the server is configured for an external network, very well may not be. lspci | grep -i ethernet returns nothing... but lspci -i ethernet returns 50 lines that look like "00:1a.4 Class 0600: Device 1022:1604" and so on – Mike May 6 at 2:00
  • lspci -i ethernet just attempts to use a file named ethernet as the master list of PCI ID numbers, instead of using the standard list at /usr/share/misc/pci.ids. If the file does not exist, you just get the whole lspci list with machine readable class/vendor/product numbers instead of respective human-readable names. – telcoM May 8 at 5:10
  • In HP c7000 series blade hardware, you can think of NICs as sort of split down the middle into two parts: the computer-side exists separately in each blade as an integrated NIC, a FlexLOM module, or a mezzanine card. The network-cable-side exists as groups of 16 ports in the I/O modules in the blade chassis. HP ProLiant BL465c Gen8 blade has a FlexLOM module which can be swapped according to what kind of network capabilities you need. It is possible that the FlexLOM module in the blade is either not installed or not compatible with the I/O module (which would cause the hardware to disable it). – telcoM May 8 at 5:27
  • Your chassis I/O modules also seem to be one of the switch/VirtualConnect types, which aren't necessarily going to allow you a straight-through network connection by default. You should use the chassis management to verify that compatible types of FlexLOM and I/O modules are installed, and the I/O module management to verify that connectivity is actually set up. A blade hardware like this has several gotchas if you're unfamiliar with it; I recommend getting someone experienced with this blade hardware to check it with you if this is your first time with HP c7000 blade hardware. – telcoM May 8 at 5:44
1

I should preface with stating I have effectively no experience with RHEL

that being said, being an HP server, which I am sure is at your work not home, and you would likely have some sort of service plan with HP, and that the server was set up by HP and installed, it is likely numerous things are configured a certain way (for whatever reason) and you should contact HP.

  • systemctl status NetworkManager; this is probably not active which is why u don't see the network icon in upper right, in rhel 7.6 with gnome; rhel 7.6 is likely to have the network driver.
  • using a combination of lspci and ifconfig and ethtool you can easily see if drivers are present at the hardware level such that linux sees and can use the network card, so it would then be a matter of enabling network and dhcp_client in rhel. Sorry not going to give a tutorial, that can be easily found by websearch on those commands... https://www.cyberciti.biz/faq/linux-list-network-cards-command/. And you will likely then see it's Intel network hardware.
  • so once you have network turned on and dchp client active, you should get an ip address and default gateway given to your server by whatever dchp server is on your network; this may not be the case if your company network adminstration restricts this access and doesn't have the MAC of your server (among other things). And then if you get an ip address, you would likely (in a corporate environment) need to specify your company's proxy address and port in network settings. And then it's likely there is a company trusted root authority certificate that you need otherwise nothing https will work and for that you would place a .pem (converted from .cer format exported from InternetExplorer on company pc) under /etc/pki/ca-trust/source/anchors/ and then as root do update-ca-trust
  • Thanks, hopefully it doesn't impact the level of help I'm getting, but this is actually at home. I bought a refurbished enclosure and blade from Newegg to try to set up a home server. I will see what drivers are present, though I did a fresh install of RHEL. – Mike May 6 at 12:05
  • 1
    wow jumping right into the deep end of the pool, if your @ home and you installed rhel7.6 off dvd yourself, then you can ignore last bullet about proxy, certificate and pki stuff. – ron May 6 at 12:46
  • 1
    answer then is simple, go to Applications menu, settings, network, turn on; it is often off by default unless during install from dvd you manually set the network to "automatically connect" and then do save. also know that if your @ home, you might want to use centos (which is free rhel) unless you purchased an activation for rhel and have registered the system with red hat for updates; you'll also want to add the repository EPEL: fedoraproject.org/wiki/EPEL – ron May 6 at 12:50
  • Thanks, yes jumping right in! I Installed RHEL 7.6 from a virtually mounted ISO. I had explored Applications/Settings/Network and didn't see anything so simple, but I will look at it tonight. I did not purchase any subscription for RHEL, so I do have limited features. I'll get CentOS on another partition if that's recommended. – Mike May 6 at 14:28
  • Ok, started over and installed CentOS (see above edits). Same issue, perhaps it's because I have a Bridge and not Ethernet? – Mike May 9 at 1:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.