1

I am customizing centos iso, i took standard CentOS-7-x86_64-DVD-1810.iso and extract it and custom folder and add my files.

Now i am recreating custom iso with below command

mkisofs -o centos-7-custom1.iso -b isolinux.bin -c boot.cat -no-emul-boot -V 'CentOS 7 x86_64' -boot-load-size 4 -boot-info-table -R -J -v -T isolinux/

its adding all files but not including one file(tar.gz) which has size of 3GB and no error.

in output no error and strange is that from one folder it including all files except this big size file.

is there any restriction?

PS: i am running this command from mac

1

Native iso9660 doesn't support files over 2GB. You need to use iso9660:1988 instead by adding -level 3 option to you command.

man 8 mkisofs:

-iso-level level

. . .

With level 3, no restrictions (other than ISO-9660:1988) do apply

. . . .

| improve this answer | |
1

If you did use a recent original version of mkisofs instead of the broken modified variant you get on Centos, you did get the following warning message:

 mkisofs: Value too large for defined data type. File xxx.tar-gz is too large for current mkisofs settings (-iso-level 3 or more required) - ignoring

So your problem was to not to use a user friendly Linux distro. The message mentioned above has been added in February 2008 already.

| improve this answer | |
  • 1
    Anyway: If the mentioned error message was missing, then the used mkisofs version is outdated since more than 11 years. – schily May 10 '19 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.