0

I have the Jodin3 jar file installed: JOdin3CASUAL-r1035-dist.jar. Can't open it.

  • java -jar JOdin3CASUAL-r1035-dist.jar does not work: Error: JavaFX runtime components are missing, and are required to run this application

  • ./JOdin3CASUAL-r1035-dist.jar does not work: invalid file (bad magic number): Exec format error

java is installed. Oracle is installed. No need to update.

sudo update-alternatives --config java
There are 2 choices for the alternative java (providing /usr/bin/java).

  Selection    Path                                            Priority   Status
------------------------------------------------------------
  0            /usr/lib/jvm/java-11-openjdk-amd64/bin/java      1101      auto mode
  1            /usr/lib/jvm/java-11-openjdk-amd64/bin/java      1101      manual mode
* 2            /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java   1081      manual mode

What else do I need to open a file in ubuntu?

=============================================

sudo apt-get install openjfx
[sudo] password for xxx: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
openjfx is already the newest version (11.0.2+1-1~18.04.2).
0 upgraded, 0 newly installed, 0 to remove and 123 not upgraded.

i have the jfx updated, thanks for trying!

I also tried this: https://www.b4x.com/android/forum/threads/solved-running-jar-on-ubuntu-linux-18-04.93400/ without any success

  • Not being a Java user myself, I'm just noticing that you select a Java 8 runtime, while the JavaFX package has 11 in its version. What happens if you select the Java 11 runtime? – Kusalananda May 5 at 21:31
  • because the jar file is kinda old (2015) the java version that is suposed to open it is the 8 instead of the newest. A lot of programs still use the 8th version – mranon May 5 at 21:33
  • Did you try running with the Java 11 runtime? Are you able to install an older openjfx? – Kusalananda May 5 at 21:43
  • yes, just tried and the outcome was the same. Just so you don't think i'm making stuff up a few months ago I installed the 8 version because file wasn't opening with the 11-th one. It worked fine back then. For some classic misterious linux reason i can't simply open the file anymore. I miss windows sometimes – mranon May 5 at 21:46
  • Your openjfx seems to be for Java 11, but Java 8 is your default runtime. Try with /usr/lib/jvm/java-11-openjdk-amd64/bin/java -jar JOdin3CASUAL-r1035-dist.jaror try something like sudo apt-get install openjfx=8.*to install the Java 8 openjfx version. – Jaleks May 6 at 21:52
0

It seems the openjfx JavaFX/OpenJFX package is missing.

You can install it with:

sudo apt-get install openjfx

Then try java -jar JOdin3CASUAL-r1035-dist.jar again.

  • it seems like i have that package, i edited my question to add the output of your command – mranon May 5 at 21:19
0

Apparently I needed Oracle's java 8. Which had it's license changed in April 16 of this year. So if others have this problem the answer is to visit Oracle's website and try to download the version from there

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.