0

I ran ddrescue for a few days, and recovered about 60G. It had slowed to a crawl, and had an ipos of about 90M. I started again, adding -a100000, and it got another 35G in only 3 hours. It started the reverse phase, and it was now making a lot of noise, and was reading very little data (the time since last read was getting up to 2 minutes), so I stopped it.

This was the original command: ddrescue -n -f /dev/sda /dev/sdc /home/B/Desktop/rescue.log (sdc is a brand new drive.)

I noticed that with -a100000 it was skipping large portions of the disk. I want to go back and to a first pass again, this time with maybe -a50000, and putting a max on how much it can skip. I am very concerned about the excessive noise at the end part of the disk (492M) in reverse. This is a damaged drive - the disk crashed when the laptop was dropped while it was running. It wasn't making noise like that before.

(The -a option causes it to move on when the read speed drops below x bytes / second.)

I don't understand what the -i option is supposed to do. It sounds like it should be where it starts, but the man page explicitly says that's not what it is. ("This is not the point from which ddrescue starts copying.") But it doesn't say, to me at least, what it DOES do. (gnu.org...ddrescue_manual.html)

How do I start the first pass over, from the beginning of the disk (where the important stuff is anyway), going over the initially skipped portions, in the forwards direction? I need to start at around 78,000MB, because it did the first part without the -a option, so it wasn't skipping ahead. (I'll probably use -a50000 with a max set to something, unless someone has a better idea. I want to get the bulk of what I can before the drive fails.)

UPDATE

I tried adding -i73GiB, but it started going forwards from about 480,000 MB, which was where the reverse had left off. So I stopped it.

I tried adding both -i73GiB and -A, but it did the same thing, -A had no effect. I stopped it again.

(-A : "Mark all non-trimmed and non-scraped blocks inside the rescue domain as non-tried before beginning the rescue.")

I don't see any other options to try.

0

I got this working. You have to add both a -i and a -s.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.